No announcement yet.

ASRock Z68 Extreme7 Gen3 + F3-17000CL11D-8GBXL x2 kit problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • ASRock Z68 Extreme7 Gen3 + F3-17000CL11D-8GBXL x2 kit problems

    Hi guys, I have just completed a brand new build and am seeing some issues with timings.

    Model of the motherboard: ASRock Z68 Extreme7 Gen3
    Model of the memory: G.Skill RipJaw F3-17000CL11D-8GBXL (two of these!)
    Model of the CPU: i7-2600k
    GPU: 2x Gigabyte GTX 460 1GB in SLI.
    OS: Win7 Ultimate x64

    I have completed a parallel build with the same RAM, and an ASUS mobo without major issues (still reads RAM as 1600mhz but works properly).

    The issue I am facing seems to relate to incorrect timings. If I allow the motherboard to automatically set the timings, it gets things ALMOST right (11-11-11-28-2N) but the rest of them are incorrect. If I run the RAM at 1600 and allow it to auto set, things mostly work, except for some games (SOURCE engine games, Deus Ex:HR, Space Marine) which crash to desktop without error. Stuff like Fallout 3, Metro 2033, Just Cause 2 run fine with no real issues (aside from Metro 2033 having minor problems but not terribly relevant).

    I initially suspected an issue with SLI, but after turning that off the problem still exists. I booted into linux to attempt memtest, it does not give me errors and simply reboots. I suspect win7 is simply handling these exceptions more gracefully.

    I understand that RAM is supposed to be purchased in a kit, however the 16GB kit was unavailable anywhere, so I have purchased 2x 8GB kits for both machines.

    If I set the speed to 2133, I can no longer boot, the machine gets stuck on bootsplash with no easily identifiable error code. If I change the detection algorithm from default to XMP profile 1.2 for 2133mhz, it flicks to 2133 and doesn't boot.

    I have attempted to copy all the timings from the ASUS mobo, and that made a difference, but is still not loading the listed applications. And I have so far not managed to boot at 2133 successfully.

    I have tried three of the available BIOS updates for the ASRock board (running L1.11 at the moment), the initial provided would not boot at all. I am currently running the most recent beta, and this kind of works.

    Am I out of luck with these two kits? Where can I find more detailed timing information for this? Do I need to reach out to AsRock for assistance too?

    Thanks, and hope very much for some assistance!
    Last edited by w0lf; 10-16-2011, 05:54 PM. Reason: SLI info added

  • #2
    Could be BIOS, could be the two sets don't want to play together......could try 1866 @ 9-10-9-28, 1.55, and CR 2T......or could stay at 2133 and raise VCCIO up about .06 or so......Believe I would check w/ ASRock also..sounds like they are trying to get some BIOS issues straightened out

    Pls offer comments on support I provide, HERE, in order to help me do a better job here:



    • #3
      Hi Tradesman,

      Thanks for that! It boots at 1866 with those settings, seemingly no issues.

      It also seems that the issue with Source games I was having is unrelated, and in fact I may have manufactured the problems I had. However, I still can't get a boot under 2133. Have submitted a request to ASRock, hopefully they will be able to help me out, or maybe a newer bios update will help me.

      I still need to try memtest again, just to confirm. But my suspicion is simply that ASRock motherboards are less forgiving than other manufacturers (going on some other existing threads).

      Thanks for the info!


      • #4
        Sounds good, keep us updated if you would

        Pls offer comments on support I provide, HERE, in order to help me do a better job here: