Announcement

Collapse

Got a technical problem?

Please provide the following information with any new post involving a technical issue with your G.Skill peripheral. This pertinent information will allow us to effectively troubleshoot and provide the best solution.

1) Software (SW) version and firmware (FW) version
2) Did this issue occur on a new software installation or software update?
3) What is the model number of your keyboard and layout? (e.g. KM780 RGB, NA English; etc.)
4) Which Windows OS version are you using? (e.g. Windows 7 Ultimate 64-bit; Windows 10 Pro 64-bit; etc.)
5) Which USB port did you plug the keyboard into? (e.g. USB3.0 in motherboard back panel, USB2.0 hub, etc.)
6) Your motherboard model number
7) Any antivirus/anti-malware software programs you have installed
8) Any other keyboard/mouse/similar device software you have installed

If you would like, you can also email this info to techsupport@gskill.com for our peripherals team to troubleshoot/replicate the issue.

Thank you!
See more
See less

KM780R software version 0.91 not working after update 1809

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • KM780R software version 0.91 not working after update 1809

    I just updated to the new release October updated 1809 for Win 10 and my software for the KM780R will not start. The software version I'm running is 0.91 and firmware is 26 I believe, but can't be sure without the program running. I have uninstalled and reinstalled the software with no change. Can you please look into this?

    If you need more info let me know and I will post it for you.
    Last edited by Bgunner; 10-11-2018, 08:40 AM. Reason: software

  • #2
    I have the same problem...

    Comment


    • #3
      After reverting to 1803 software worked again. But this is G.Skill we are talking about here.... can't fix the firm ware corruption issue that has plagued this keyboard from day one. Other than RAM I will not be buying any other products from this company again because there customer service and help leaves way to much to be desired. These are PnP devices, when I have to,6 times a year, reinstall the firmware for the keyboard this is not plug and play, this is plug fix play, plug fix play, plug fix play.

      Now that Microsoft has released an updated version 1809 to the insider program we will just have to wait and see what happens. If ther is an issue still do not expect G.Skill to help in any way as this is their track record with keyboards and peripherals.

      Comment


      • #4
        can confirm it is not working on 1809, installed the software on my laptop running 1803 and worked smoothly...

        Comment

        Working...
        X