No announcement yet.

SSD on the way out?

  • Filter
  • Time
  • Show
Clear All
new posts

  • SSD on the way out?

    Some time ago, the system with my Falcon 64GB SSD in it restarted while watching a video. When it tried to boot again, it said it was missing the boot manager. When I got into the bios, the drive showed up. I reset the bios and the system booted.

    Unfortunately, every day that week the same cycle persisted. It would crash, fail to boot. I figured out that the drive must be actually disappearing when it crashes. If I shut down the system and reboot, the drive is detected but set as the 2nd hard drive to boot from. If I just let it restart, the bios does not detect the drive.

    Curiously, the problem went away before I found a resolution. It's been gone for some time but resurfaced recently. All week we're back to what was happening before.

    So the process is now, after the crash, to shut down the system go into the bios and set the Falcon as the boot device again - then it starts fine until the next day when it crashes.

    Any ideas?

  • #2
    Hi Tyanta,

    i think that's a software problem, please check the link and see if your problem could be solved:


    • #3
      Sorry, I should have been more clear. The reason the "boot manager is missing" error shows up is because the SSD dissapears from the system making my data drive the first boot device. Of course my data drive doesn't have an OS on it, hence the error.

      I then need to cold boot the system so the SSD is detected again in the BIOS, and set it as the primary boot device. Once that is done, the system boots as it should and works fine until the next crash. This seems to repeat every ~24 hours.


      • #4
        Hi Tyanta,

        please check the sticky thread, using the firmware1916/with clean function to secure erase the drive, and re-install the firmware1916, then upgrade to firmware 2030.

        this way should be able to solving your problem.


        • #5
          So I have followed the instructions in this thread: however I never got to the point of needing to specify cleaning. I just initiated fw flash & it did say the drive was not clean so I assumed it was doing the clean prior to flashing.

          I just updated to 2030 now.

          Should I just use it as is or should I perform a secure erase on it as well just to be safe?


          • #6
            I looked back and found my old post:

            I'm thinking there might be a problem with the drive seeing as the only time I ran benchmarks on the drive it got low write scores and the second time after secure erase it generated a write error after which the drive to not show up in the bios.

            It almost seems like there's a "bad" part of the drive that a) caused CrystalMark to crash back then and b) my operating system to crash now.

            I haven't done anything yet as I'm not sure I want to run secure erase or a benchmark on this drive.

            It serves in a HTPC as the boot drive with basically everything moved to the data drive so it hasn't had a hard life.

            Edit: This sounds very similar:
            Last edited by TyantA; 03-18-2012, 12:22 PM.


            • #7
              the secure erase will save the performance immediately, but it's not the requirement.
              however, after a long time usage, secure erase resets the drive to new condition, and can correct some issue also.


              • #8
                I didn't end up doing the secure erase this time.

                So far, I've installed Windows and for the past day, the system has been stable. We'll see if this persists.

                Thanks for your help.


                • #9
                  Hi, i'm having the exact same problem the last couple weeks, have a falcon ii 64gb, bought it jan 10, so a few month out of warranty now, which is so annoying.

                  A couple times a day, windows hangs, and then the system just crashes, restarts with no access to the hard drive.. have to shutdown, and then tell it to boot with from the ssd again.

                  I've installed a ssdlife program, only thing i could find to test an ssd? and it shows it's healthy with 60% life left. i'm guessing bassed on hours running?

                  I upgraded the firmware a few months ago, first time ever, to 2030. which now looking again, maybe wasn't the right thing to do.. maybe i should of gone to the 1916 which said "falcon II only".. as the 2030 says "falcon only", but never had any issues for the last few months since doing it.. apart from now. i've tried the 2 other sata cables in the pc, data and dvd rom.

                  Only other thing i can think of is to do some kind a wipe on the drive and start again, which i've never done, didn't have to with trim.

                  Should i be installing the 1916 firmware? any other things i can try, to save this drive


                  • #10
                    Hi subwars,

                    really sorry to ask you re-install the 1916 firmware, someone stick with 1916 cause they got problem with 2030, but totally fine with 1916. might be a hardware compatible issue, please try the 1916 to see what happen!!


                    • #11
                      ok, i shall try going to 1916, should i do anything else at the same time, like a write zeros or anything too that might help?


                      • #12
                        will suggest secure erase the drive, please back up all of your data as well.


                        • #13
                          well ya wouldn't belive it, but after my last crash, right before i posted yesterday, i was messing around taking the sata cable off an on again. i was looking at the contacts on the drive itself, they looked fine.. but thought i'd give them a clean anyway.

                          24 hours now and no crashes.. so its looking like all the time it was a dirty contact


                          • #14
                            Parted Magic reports at least 5 bad sectors on the drive as I suspected previously.


                            • #15
                              I ran the firmware update / clearner again thinking I'd try with 1916 fw again as it stopped responding after my system went into hibernation.

                              During the fw update process, it said the drive needed to be cleaned. Once it said it was done, I asked it to clean again. It keeps finding bad blocks and saying erase failure:
                              Last edited by TyantA; 05-04-2012, 03:24 PM.