baymavi - vevobahis - mobilbahis - https://guncelgirisi.com/. instagram takipçi satın al - instagram takipçi satın al mobil ödeme

Announcement

Collapse
No announcement yet.

Dead Falcon II

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dead Falcon II

    I have a Falcon II FM-25S2I-64GBF2. It had firmware 2030 on it and was running fine.
    The other day, the SSD stopped being recognised in BIOS and I'm assuming I've lost all my data.

    If I put the jumoer on the SSD and boot, the laptop recognises the drive (as a 128Gb) but can't do anything with it. As soon as I remove the jumper, it's back to being unrecognised.

    I've tried formatting and updating the firmware again , but I just can't get the disk recognised without the jumper attached. I can't even boot from CD if the SSD is present without the jumper. I've tried various combinations with IDE and AHCI set.

    The same applies if I connect it as an external USB drive - it's not recognised with no jumper, and recognised as a 128Gb drive that can't be initialised with the jumper on.

    Please advise:
    1. How can I tell if the SSD is totally dead?
    2. If it's not dead, what are the steps to get it working again?

    Thanks.
    Last edited by m3it; 06-12-2013, 08:19 AM.

  • #2
    Hi,

    Please try the firmware 1916 with clean function, clean the SSD first, and then re-install 1916

    If these steps doesn't work, please contact our RMA department for replacement.

    Comment


    • #3
      I have tried 1916 and couldn't get it to work (there are so many versions though and I don't know if I used the right one.).

      The drive is probably around 3 years old - is RMA still available?

      Thanks.

      Comment


      • #4
        Use the clean function first, then re-install 1916:
        http://www.gskill.us/forum/showthread.php?t=5172

        As i know, the Falcon series is two year warantee, please note!

        Comment

        Working...
        X