No announcement yet.

Need help with lighting software and asus incompatibility

  • Filter
  • Time
  • Show
Clear All
new posts

  • Need help with lighting software and asus incompatibility

    I need some help, I just built a new system which includes an Asus x570s crosshair VIII Dark Hero and a kit of Trident Z Neo Series 32GB (4 x 8GB) DDR4 3600 (PC4 28800) F4-3600C16Q-32GTZN RAM.

    I have tried on multiple occasion to install, Uninstall, and re-install the g.skill trident z lighting software as well as Asus armoury crate, in different combinations. And no matter how many times I do it I can't get the g.skill software to see the RAM. Armoury crate sees the ram but the g.skill lighting software does not.

    Also, lately, I am unable to uninstall the g.skill software due to an "unins000.dat does not exist" error.

    I would much rather use the g.skill software to control my trident z lighting but I just can't get it to work.

    Any and all help is greatly appreciated.

  • #2
    Are you using the latest BIOS for the motherboard? Have you tried the clean uninstall guide?


    • #3
      I am using the latest BIOS, 3801 I believe, not at home to check at the moment but the system was built this last Saturday and I flashed the latest BIOS.

      I did try the uninstall guide and it lead to even more problems, like the one I am having now that I can't even uninstall the g.skill software. The issue is that the uninstall guide is over a year and a half old and aura sync is now part of armoury crate, no longer stand alone. As a matter of fact after I removed ene.sys file and re-istalled g.skill software, it still would not see my ram and I could no longer get armoury crate to work at all.

      I had to restore my windows from a day old restore point to at least get armoury crate to work.

      Edit: Ok, I just checked and my BIOS version is 3801 dated 7/30/2021. And I just realized something, the uninstall guide is saying to delete all lighting software, does that include corsair icue and evga unleash as well? If I have to delete 3 apps just to get 1 to work that seems a bit excessive to me and honestly not worth the headache.
      Last edited by Marty Z; 09-15-2021, 04:16 PM.


      • #4
        iCue and some other RGB software are known to interfere with or completely block access to these hardware resources, in some cases even when DRAM control is disabled in their program settings. In that case Armoury Crate or Trident Z Lighting Control won't be able to "see" or access the modules. To confirm it, you can temporarily remove those programs and see if that restores RGB control via Armoury Crate or Trident Z Lighting Control (only install either or). Also make sure to restart the system at least once after the installation/uninstallation.
        Team HardwareLUXX | Show off your G.SKILL products!


        • #5
          Armoury crate sees my DRAM, g.skill software does not. I would prefer to use the g.skill software because the armoury crate options are very limited. I can't control individual sticks or individual LEDs with armoury crate. I can try uninstalling icue and re-installing g.skill. But I still have a problem, I can't uninstall or re-install g.skill because of the "unins000.dat does not exist" error


          • #6
            Well, I ran some tests and I think it is the corsair icue software messing up g.skill software. I want to try uninstalling or disabling icue and see what happens. But still, I can't uninstall the g.skill software to re-install it


            • #7
              You can manually remove it, if you messed up the order in the guide. There also are generic removal tools that can do it semi-automatically. I personally prefer doing it manually instead. Make sure to reboot and then execute the installer with admin rights. Otherwise the IO driver can not be installed. You should get a prompt for the driver installation during the setup. After another reboot TZLC should be able to control all modules.
              Team HardwareLUXX | Show off your G.SKILL products!


              • #8
                How do I remove it manually? I tried deleting the folder, and restarted. Then the install would not even run. Could not find a registry entry for it.


                • #9
                  I think i'm done with this, I just tried to the entire uninstall process and it screwed up armoury crate again after re-install, I think the procedure and .bat file needs to be updated for the latest version of armoury crate, it is over 1.5 years old. Luckily I created a restore point right before trying it again. Now I just want to uninstall g.skill and be happy with the armoury crate limited options.


                  • #10
                    Maybe try GeekUninstaller (free for personal use) or a similar tool if manually removing the files didn't work.

                    The guide still works just as intended for me, so I am not sure what exactly the issue may be. If you want to use TZLC, you have to uninstall Armoury Crate, since both apps cannot be used in parallel, because they share software components. So that is why you start by uninstalling Armoury Crate, restarting and disabling Armoury Crate in BIOS (otherwise it will automatically be reinstalled).

                    The clean up guide is for when after uninstalling Armoury Crate, iCue etc TZLC can still not access the modules. In most of these cases even after uninstalling those programs there may be components left on the system that create conflicts or prevent installing a different RGB software. So yes, if you follow the guide and manually remove the packages in %appdata% those programs will stop working - but they should no longer be installed in the first place.

                    Edit: It basically works in the same way with ASRock Polychrome RGB / RGB Sync, Gigabyte RGB Fusion 2.0 and MSI Mystic Light / Dragon Center / MSI Center.
                    Team HardwareLUXX | Show off your G.SKILL products!


                    • #11
                      Originally posted by emissary42 View Post
                      start by uninstalling Armoury Crate, restarting and disabling Armoury Crate in BIOS
                      Disabling Armoury Crate in the BIOS. This appears to be a very important step, that is not in the guide.

                      I will try GeekUnistaller to remove the G.skill software and see if it works.



                      • #12
                        The only thing that worked was geekuninstaller, thanks for that advise. At this point i'm leaving it alone and having Armoury Crate control the RGB.