No announcement yet.

G.Skill Trident Z RAM can't be recognized or change color on G.skill & MSI software

  • Filter
  • Time
  • Show
Clear All
new posts

  • G.Skill Trident Z RAM can't be recognized or change color on G.skill & MSI software

    So the story goes like this, It worked fine with both G.skill & MSI mystic light software when I finished building my PC. But after a week, I wanted to cycle my ram through 2 colors, which you can't with the G.skill & MSI software. So, after a bit of research, I've read an old post (2017) somewhere on Reddit or some other forums posted that you can download & use Asus aura sync on an MSi motherboard to control the trident z RGB lighting, and the aura software supported 2 color cycling. So just like that, I went to Asus's website & downloaded the Aura Sync software (yes I'm kinda an idiot for doing this). But when I tried install the software it went halfway & stuck at AaC.HAL or something close to that. In the end, I just canceled the installation and leave it be. After that I've noticed that my RAM can't change color nor can be recognized by both software.

    UPDATE: Tried my RAM on a friend's PC who uses ASUS Strix B450-F Motherboard. G.skill software won't work on the RAM either but the Asus Aura Sync Software recognized the RAM & able to change color.

    What I've tried :

    -Delete & Removing anything that is related to Asus (Manually & used CCleaner too)

    -Uninstalling & reinstalling G.Skill software & MSI Mystic Light software

    -Re-seated the RAM

    -Uninstalling all RGB software from the computer & reinstalling G.skill

    Specification :

    MOBO : MSI B450 Carbon Pro AC

    CPU : Ryzen 7 2700X

    GPU : Gigabyte GTX 1070 Windforce OC

    RAM : G.skill Trident Z NEO 32GB 3600MHZ

  • #2
    Are you using the latest BIOS for the motherboard?

    Do you have modules installed in second and fourth slots away from CPU?


    • #3
      ASUS has background apps running even if you delete them, try regedit and search then delete anything from ASUS. Check your processes in the task manager, you most likely will find there are two running from ASUS. Run %appdata% in a desktop search and delete the ASUS data there as well.


      • #4
        be sure to use the % quotes.