No announcement yet.

F3-2400C10Q-32GTX + ASUS Maximus IV Extreme-Z + Intel i7-3770

  • Filter
  • Time
  • Show
Clear All
new posts

  • F3-2400C10Q-32GTX + ASUS Maximus IV Extreme-Z + Intel i7-3770


    I'm new to the overclocking world but have much experience in building and troubleshooting PCs (was part of Tech Staff in high school). I've tried pretty much everything I could think of over four days to get the RAM to work and so I've come here to the forum to kindly ask for your assistance.

    Here's what I said in my initial email to tech support:

    "I have a desktop computer with an i7-3770 and an ASUS Maximus IV Extreme -Z motherboard (chipset is Z68)l. Previously to my installation of the new RAM, my system's memory was 4 x 4gb sticks of 1600 MHz RAM (16 total). I installed all 4 sticks of the new ram: 4 x 8gb sticks of 2400 MHz RAM but the system refused to post. Having only 2 installed, I was able to boot with XMP profile 2 which is 2200 MHZ. I tried all sorts of settings and configurations over three days such as adjusting voltages, overclocking my CPU through the multiplier, etc. I am not sure if the other two sticks of ram are bad, if so I will RMA them. But first I would like to see if I can get all 4 sticks in my motherboard.
    Please advise on what your recommended settings are for the BIOS."

    I've received a reply a day later approving my account so I could post here as well as a question regarding if I have tried using just any set of 2.
    I'll answer it here and explain what I've done so far:
    • Reseated RAM multiple times
    • Reseated and reapplied thermal paste to CPU (in case pins weren't making contact)
    • Reflashed the latest BIOS (which I already had)
    • Manually updated BIOS components using UBU
    • Set everything to AUTO
    • Set primary, secondary, and tertiary timings as well as voltages manually for 2400 MHz operation
    • Tried both XMP profiles
    • Ran Memtest on the 2 sticks that worked.
    • Tested each stick individually and 2 of the 4 failed (memory not installed error comes up on debug LED)

    I have searched these forums for an answer before posting and the one with the closest specs was this one:
    It didn't work for me.

    I would greatly appreciate any help in this matter.

    Edit: To me there's no other explanation than that the two sticks I tested are bad. I plan to RMA if that assumption is correct.
    Last edited by Sohan24; 03-07-2016, 06:08 PM. Reason: Forgot to add that 2 sticks are rejected by the mobo.

  • #2
    Recent Update

    I can't get the 2 working ones to go to 2400 MHZ (manually or with XMP) and XMP Profile 2 (2200 MHz) isn't stable: occasional BSODs.


    • #3
      Not Alone

      It's not the first time multiple sticks in this series were found to be DOA.

      He also used the same methods as me and discovered the sticks to be faulty.
      I wish I had read this thread and immediately requested a RMA before spending days trying to figure out what was wrong with my system.

      I am definitely going to request an RMA now.


      • #4
        Sent in the sticks and got a replacement. All four sticks are detected by OS and work [32 GB]. Still have the issue of not being able to reach 2400 MHz. Highest is 2133. I've loosened the timings but that didn't help at all. I believe the solution may lie in messing with system voltages. On my BIOS, VCCIO and VCSSA are tied together into VCCIO and I have that at 1.25.
        Any advice on other voltages?


        • #5
          1.25V should be sufficient, have you tried a slightly higher voltage? If nothing will work, it may be a CPU limitation. Only a small percentage of 3770 CPUs are capable of DDR3-2400