No announcement yet.

Memtest86 v6.0 Test 13 (Hammer Test) errors

  • Filter
  • Time
  • Show
Clear All
new posts

  • Memtest86 v6.0 Test 13 (Hammer Test) errors

    Hi all,

    I've been encountering errors with my G.SKILL memory using Memtest86 v6.0, specifically on Test #13 (Hammer Test), and I'm hoping someone can help.

    I recently built a new desktop using a Gigabyte z97 motherboard (GA-Z97X-UD5H-BK) and an Intel i7-4790k processor. I used G.SKILL Ripjaws X Series 8GB (2 x 4GB) DDR3 memory (F3-14900CL8D-8GBXM ) in it initially but, after having some system crashes, I decided to check the memory for errors. After testing for a few hours with Memtest86's latest version (v6.0) I found that the memory passed all the tests except for Test 13, called the Hammer Test (apparently it involves hammering memory rows with data). In this Hammer Test, dozens of errors showed up, making me wonder if my memory was bad...

    Thinking that the RAM was defective, I then returned the memory to the online vendor I purchased from, and bought G.SKILL Sniper Series 8GB (2 x 4GB) DDR3 memory (F3-14900CL9D-8GBSR) instead. This module set was specifically listed as compatible with my motherboard on Gigabyte's website, so I thought the issues might be cleared up.

    However, after receiving and testing the new memory, it again passed MemTest86's tests in every way except for Test 13, where again dozens of errors showed up (it was actually slightly worse for errors than the previous memory I tried).

    All these tests were performed at 1866MHz using the XMP profile for each memory set. I tried turning off XMP and running the memory at 1600MHz, but this only reduced the number of Test 13 errors, it didn't completely eliminate them. I also tried upping the voltage on both sets of RAM, but this didn't solve the issue either.

    At this point I'm baffled... Did I get faulty RAM two times in a row? Or is this a common issue with modern memory that was undetectable before (Test 13 for hammering rows was only recently added to MemTest86 in Feb. 2015) that isn't anything to worry about? (After all, the memory passes previous version of MemTest, just not v6.)

    I really hate returning the memory for a refund and ordering new modules again, just blindly hoping that the new set won't have Test 13 errors... Though I also don't want to have passive data corruption occurring from faulty memory or periodic crashes/freezes either...

    Can anyone shed some light on this issue?

    Here's a link to MemTest's website, where they discuss the Test 13 memory issue:


    Last edited by Gibraltar; 03-06-2015, 11:14 PM.

  • #2
    Use another memtest, we don't use that one because results are not accurate. Have you tried to boot p the system to see if it is stable?

    memtes86+ is better


    • #3
      Thanks for the reply!

      The system seems stable at boot up and a couple passes with MemTest86+ shows no errors, though the only time any testing ever showed errors was with MemTest86 (v6.0) and its Test #13. I'm not sure what's going on there... I don't know if the error reports are just inaccurate, or if it's really nothing to worry about (since the test seems to measure very extreme scenarios that wouldn't occur in everyday usage)...


      • #4
        Not all tests are accurate, they may not even be designed for the platform, so we recommend using only specific ones that are proven to work properly.