Got a technical problem?

Please provide the following information with any new post involving a technical issue with your G.Skill peripheral. This pertinent information will allow us to effectively troubleshoot and provide the best solution.

1) Software (SW) version and firmware (FW) version
2) Did this issue occur on a new software installation or software update?
3) What is the model number of your keyboard and layout? (e.g. KM780 RGB, NA English; etc.)
4) Which Windows OS version are you using? (e.g. Windows 7 Ultimate 64-bit; Windows 10 Pro 64-bit; etc.)
5) Which USB port did you plug the keyboard into? (e.g. USB3.0 in motherboard back panel, USB2.0 hub, etc.)
6) Your motherboard model number
7) Any antivirus/anti-malware software programs you have installed
8) Any other keyboard/mouse/similar device software you have installed

If you would like, you can also email this info to for our peripherals team to troubleshoot/replicate the issue.

Thank you!
See more
See less

Software bug and lighting issue.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Software bug and lighting issue.

    Hi, I got the km780 mx, not the mouse with no rgb, the red one, and I didn't know what mr was. So, I uninstalled the driver, and installed another one. When it was trying to update, it said update failed. So I close it. Once I opened it, the RGB still worked. Then, the next day, which is this day, I learned what MR is. I even tried to do a restore point and install it. Thee bugginess is that I have the dotNet framework of 4.7, and it keeps having errors, and I press continue. Then it says Invalid in a window. Once I tried to save a lighting mode while it was buggy to see of I press any M1, M2, or M3 would work as it did the previous day. Tell me if it is a keyboard issue, driver issue, or internal keyboard driver issues that I need to reset. Or, firmware. Please help. It may be a .Net issue, or dotNet. BTW, the typing is totally normal and there is a macro that is in the firmware, I think when I learned what MR is. ANd used it on the G1 key. It's just to do ctrl + shift. Thanks. BTW, I hope it gets solved. Also, I might add pictures later.
    Last edited by lagcatfour; 12-26-2017, 02:40 PM. Reason: Important info.

  • #2
    I fixed it. It was just old 2009 firmware that broke. Had to reinstall it using the papercclip methoad and going to the post on the forum to install.