No announcement yet.

[Trident Z RGB Software] Installation - Unblock before extracting

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Trident Z RGB Software] Installation - Unblock before extracting

    If the installer is not completing properly, not detecting modules, or giving errors, please make sure that the *.exe installer file is unzipped to a known location, like your desktop.

    If you are using the built-in Windows File Explorer to extract the files, please make sure to "Unblock" the ZIP file first. To do so, right click on the ZIP file and choose "Properties". Under the General tab, make sure that "Unblock" is checked at the bottom. After clicking "OK", extract the contents to a folder for the installation. This will ensure that the installer is properly extracted for installation. See the screenshot below for the location of the "Unblock" checkbox.

    Attached Files
    Last edited by G.SKILL; 01-15-2018, 10:02 PM.

  • #2
    Same for WinRAR

    I can tell you that you need to "unblock" as well with WinRAR.

    I really wonder if you have posted that before my replies I haven't seen it and replied it to all the "issue" posts. Well nevermind if you used my information, most important is that this issue is solved.


    • #3
      I've done all this, and every other suggestion to get these RAM sticks to work. Even the newest Asrock BIOS update didn't help. The only way the modules are detected, and I can change the LED's is to run them in single channel mode, or put them in slots that causes my system to crash for dual channel. I'm pretty much left to buying another kit so all 4 DIM's are filled to get this to work. But I"m not going to pay those insane prices just to control some RGB stuff.


      • #4
        I had v1.00.08 installed previously. I noticed v1.00.28 available, so I downloaded it. When I first tried to uninstall the old version, I was getting error messages. So I used IObit Uninstaller to completely uninstall it. That was successful. Once that was out of the way, I tried installing the new version and now I'm getting another error "An error occurred while launching the setup. The remote procedure call failed."

        I tried removing the "NeedReboot" flag in the article listed below and that did not help. I'm still getting the same error...

        I've also checked "Unblock" in the properties and tried installing with "Run as administrator".

        Again, v1.00.08 worked just fine prior to all of this. Now I'm screwed and have no software installed. Does anyone have a solution to this error?


        • #5
          Hi plyab0yyy,

          Can you follow the clean uninstall guide for the v1.00.08 version? Please do Steps 1-4, and then you should be able to install the new version correctly.

          Guide link:

          You'll also need the original v1.00.08 installer ZIP file to do the clean uninstall.



          • #6
            That did not work. I downloaded and extracted the 1.00.08 beta. Then I tried running the “ARASUninstall.exe” file. That briefly opened a black window (see attached screenshot). After that, I tried running the Setup.exe and got the same error message I've been getting (see attached screenshot). Please advise.


            • #7
              Please advise, G.Skill!


              • #8

                Let's move this to the thread you created, since it's not relevant to this particular thread.


                Please see there for our response. We'll need some more information to figure out what you did and how we can help.


                • #9
                  I've responded in that thread and via email as requested. Please have someone follow up. Thank you.