Announcement

Collapse
No announcement yet.

Trident Z RGB Software Error "An error occurred while launching the setup..."

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trident Z RGB Software Error "An error occurred while launching the setup..."

    I had v1.00.08 installed previously. I noticed v1.00.28 available, so I downloaded it. When I first tried to uninstall the old version, I was getting error messages. So I used IObit Uninstaller to completely uninstall it. That was successful. Once that was out of the way, I tried installing the new version and now I'm getting another error "An error occurred while launching the setup. The remote procedure call failed."

    I tried removing the "NeedReboot" flag in the article listed below and that did not help. I'm still getting the same error...

    http://www.gskill.us/forum/forum/pro...lation?t=14764

    I've also checked "Unblock" in the properties and tried installing with "Run as administrator".

    Again, v1.00.08 worked just fine prior to all of this. Now I'm screwed and have no software installed. Does anyone have a solution to this error? Win10 64bit with 32gb of trident z rgb.

    PS - I've emailed, called (spoke to Alex who referred me back to email), posted here, and pm'ed... it's been days and not one response. Pathetic customer support.
    Attached Files
    Last edited by playab0yyy; 03-05-2018, 09:54 AM.

  • #2
    Hi playab0yyy,

    Apologies for the delayed response of our technical support team. We're now working with the tech support team to provide support for your issue.

    It seems like you have tried multiple related and unrelated methods to remove and install the software. We're having trouble finding out what you did with all the posts and fragmented feedbacks. Could you let us know, in order, what you have done? This may help our tech support team to undo or cleanly remove the software. And it would be a great help if you can let us know which software versions you've attempted to install or remove.

    At the moment, it seems like IObit Uninstaller may have changed something that it wasn't supposed to. We'll see if we can run tests to confirm this, and if it is the case, then see how to resolve this issue.

    A hardware list would also help us understand your situation. Would you mind sending us the following information to techsupport@gskill.com? Our tech support will follow up through email.

    1. Motherboard model, and BIOS version
    2. Windows version
    3. CPU model
    4. Memory kit model number (begins with "F4-" on the label of each module)
    5. Memory module serial numbers (begins with "17-" or "18-" under the bar code of each module)
    6. Please open the "Run" dialog, and enter "services.msc". Can you send us screenshots of the list of services?
    7. What did you click on, in order for the remote procedure call error to open? The setup to which version of the software?
    8. Which software versions have you tried to install or uninstall?
    9. Which procedures have you tried using?
    10. Have you ever installed ASUS Aura or any other lighting control software?
    11. Which IObit Uninstaller version did you use?

    Comment


    • #3
      I've emailed them numerous times over the past week and they have NOT replied once. I just emailed them again with the information you requested. Below is a copy of what I sent them.

      1. ASRock Fatal1ty Z170 Professional Gaming i7 DDR4 LGA 1151 Motherboard - BIOS 7.30 (fully updated)
      2. Windows 10 Pro 64-bit Build 16299
      3. Intel Core i7 6700K Unlocked 4.0GHz Quad-Core Skylake Processor
      4. G. Skill 32GB (4x8GB) TridentZ RGB Series DDR4 3000MHz PC4-24000 CL15-16-16-35 RAM F4-3000C15D-16GTZR
      5. 1709A4000577433, 1709A4000577434, 1709A4000577435, 1709A4000577436
      6. 6 screenshots of list of services attached (along with screenshot of dump file from trying to run v1.00.08 software currently installed).
      7. Running the Setup.exe (as Admin) for v1.00.08, v1.00.22, and v1.00.28 all give me "The remote procedure call failed." error.
      8. I've tried v1.00.08, v1.00.22, and v1.00.28 (always using Run as Admin)
      9. Below is everything I have tried...
      10. Corsair Link 4 (Currently uninstalled)
      11. IObit Uninstaller 7.3


      1) v1.00.08 was initially working fine around March 2017 when I first got it.
      2) February 2018 I tried opening the software and got "G.Skill has stopped working".
      3) I checked your website and found v1.00.28, so I downloaded it.
      4) I attempted to uninstall v1.00.08 but was getting errors. So I downloaded IObit Uninstaller 7.3 to complete the uninstall.
      5) After that uninstall, I tried installing v1.00.28 but got "The remote procedure call failed." error.
      6) I tried removing the "NeedReboot" flag but that did not help. (http://www.gskill.us/forum/forum/pro...lation?t=14764)
      7) I've made sure to "Unblock" on every zip file I've accessed.
      8) At some point I did install Corsair Link 4, but have since uninstalled it.
      9) I also tried clearing the CMOS. Didn't make a difference.
      10) I used a system restore point from about a week ago and now I'm back to where I was initially, with v1.00.08 installed, but when opening it I get "G.Skill has stopped working".
      11) I tried following your clean uninstall guide (http://www.gskill.com/gskill-device/...guide_easy.pdf), but that did not make a difference. I tried running the ARASUninstall.exe file. That briefly opened a black window (see attached screenshot). After that, I tried running the Setup.exe and got the same error message I've been getting (see attached screenshot).
      Attached Files
      Last edited by playab0yyy; 03-05-2018, 06:56 AM.

      Comment


      • #4
        Thanks for the info. We'll run through a few test cases to see if the third party uninstall utility messed up anything in Windows. Or if the memory became faulty during this time, causing the initial failure in #2 of your description; and if so, then RMA may be required.

        We'll give you an update once our tests are complete. Thank you!

        Comment


        • #5
          Please note, the "G.Skill has stopped working" error when trying to open the software happened before the uninstaller was ever used. Also, how could faulty RAM cause an installation error?

          Comment

          Working...
          X