Announcement

Collapse
No announcement yet.

Warranty

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Warranty

    Hi,

    I've purchased a few days ago :

    Memorias DDR3 > 1600 - G.Skill Sniper DDR3 1866 PC3-14900 8GB 2x4GB CL9 - F3-14900CL9D-8GBSR


    .. together with the rest of components to mount a PC.

    Since the very beginning I suffered issues isntalling OS W7Ulti 64bits... And I could only manage to do with only 1 SIMM = 4gb. I thought it was a limitation of new AMD F 8 core processor and new Motherboard... finally I realiced that the issue was the MEMORY.

    I sent back to my Internet provider in Spain...and they said to me that one SMD condenser was missed so the warranty was lost...and they could not do anything for me except sending to you to decide if was or not covered by your company.

    I couldn't believe this... I did nothing to the simms... they gave mi problems from the very beginning and now I'm guiltly .????

    They want to send to you the Simms...and in two or three months I will know if finally the memory is covered or not by warranty... if NOT I have TO PAY extra transport cost...and customs??? ... this is a crazy situation.

    One SMD component is lost... with no marks, scratchs or strange manipulation... all is perfect as was in origin... ??


    Please tell me something to know what to do... I don't want to send anything to you with no guarantee of being covered by warranty...why you cannot contact the dealer and ask him to send you pictures of lost SMD area to find out if it is missed in origin of after bad manipulation...

    the company is www.pccomponentes.com in spain.

    Thx and rgds.

    Ignacio.

  • #2
    Please ask them to send picture to rma@gskill.com for approval.

    Thank you
    GSKILL TECH

    Comment


    • #3
      Hi,

      Thanks for your kind attention.

      I will ask that dealer to send you the pictures.

      Believe me that after starting with spectrum 25 years ago, this is the first time I've problems with a memory loosing SMD components... Believe me that I just did what whichever do with the simms... just plug it.

      THx and keep waiting for your answer.

      Br.
      IGnacio.

      Comment


      • #4
        Hi again,

        They sent me a link to a video where they show the missed SMD...

        as you will see there is no any signal of bad usage...no scratchs, etc.

        THis is the link:

        http://www.pccomponentes.com/flvplay...=RMA-48356.flv

        Believe me that this component was missed before I used the memory.

        Rgds.
        Ignacio.

        Comment


        • #5
          Hi, I'm not sure if they will send you the pictures, but they sent to me.. this are the links to the pictures.


          http://www.pccomponentes.com/videos/RMA-48356A.JPG

          http://www.pccomponentes.com/videos/RMA-48356B.JPG

          http://www.pccomponentes.com/videos/RMA-48356.JPG


          One SMD component seems to be wrongly welded and other is missed ?? ... and as you see no external damages, scrachts are appreacited...

          thx and best regards,

          Ignacio

          Comment


          • #6
            Did you email to rma@gskill.com? They handle international RMA.

            Thank you
            GSKILL TECH

            Comment


            • #7
              Ok today I've sent an email to rma@gskill.com with URL to this post.

              thx
              Ignacio

              Comment

              Working...
              X