baymavi - vevobahis - mobilbahis - instagram takipçi satın al - instagram takipçi satın al mobil ödeme


No announcement yet.

How to use Boot CD and upgrading SSD firmware.

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by kwilks3 View Post
    The download link does not work for me. It keeps going to google documents saying the file is too large to be virus scanned, and does nothing after that.
    I had the same experience but if you skip the virus scan thing the file downloads...and actually works...or at least worked for me!

    (and after only 4 days of reading/re-reading/deciphering the posts in this forum)


    • #17
      Originally posted by SMELZBAD View Post
      "This storage can't be recognize at RAID or IDE mode when using upgrade tool.
      Please set AHCI mode."

      "Please set SATA as IDE mode in BIOS first before upgrading new firmware. "

      Which is it...AHCI or IDE?

      And there is no mention of installing the jumper on the drive...I do need to install the jumper to upgrade firmware right?
      FALCON = IDE Mode
      Firmware ver = 1916 or Clean function ...need use jumper
      Firmware ver = 2030 ...not need jumper


      • #18
        K...thanks for the clarification...

        I was able to flash to 1916 using the boot disk and a jumper on the SSD. Had to use the boot disk because I could find no way to get the SSD listed as "Disk 0" without removing the IDE drives that contained my cloned OS that I was hoping to use to boot the system with.

        Staying away from 2030 as acording to other posts in this forum there seem to be stability issues with it.


        • #19
          Great read.. I needed this for my Phoenix Pro 120GB, Vista could not recognize the frive but the mobo could. I followed step by step with happy results, loading Vista now, thnx OP.



          • #20

            I have a Phoenix Pro 120gb. Now i want to upgrade to 4.2 firmware. I run the original Firmware update tool from the boot image, but it cannot detect my drive
            I use Windows 7 SP1, Microsoft AHCI driver, and set HDD mode in BIOS to AHCI
            I'm using the Dell Latitude E6410 with intel core i5
            What can I do now?


            • #21
              This is a very informative forum. I think i could use some of this suggestions...
              we were born to succeed, not to fail


              • #22

                So from what I understand I must reset my hard drives to upgrade my firmware? I have 2 x 120 phoenix pro's in Raid 0. In windows the flash program doesnt detect my drives then in dos it forces me to reset the drive. No other option so I dont have to go through the back up process?


                • #23
                  Doesn't update

                  When I have SSD Update open, after I click on Download Firmware to Selected Drive and it says Download firmware complete, and I click on the Refresh Driver List, when my SSD comes back up, it does not show the newly updated firmware, just the same firmware I used before... Did it even update?