No announcement yet.

Drivers no more recognize my sr910 headset

  • Filter
  • Time
  • Show
Clear All
new posts

  • Drivers no more recognize my sr910 headset

    Hi, am I the only one with win 10 pro 64bits who has lot of trouble at each windows update ? Now I can't use gskill drivers for my sr 910...driver doesn t recognize it and ask to plug it to install the driver...why can t I even install the driver if the headset is not recognize (G.SKILL_RIPJAWSHeadset_SR910_Setup_V0.1.0.19b) ??? After all the driver is record on my PC not the headset...

  • #2
    Hi GorgorB,

    I also am using Windows 10 Pro 64. However, I am finding it difficult to understand your post. Please clarify what the problem is. From what I can gather, your headset is not being recognized. First things first. Unplug your headset and plug it into a different USB port. If it is still unrecognized you need to uninstall the driver. Also, there is no need for you to use G.SKILL_RIPJAWSHeadset_SR910_Setup_V0.1.0.19b so uninstall the GSKILL program. Then unplug your headset. Then restart your computer. Then plug your headset into a different USB port. Let windows automatically find and install the correct driver. Afterwards you can reinstall the GSKILL program but I would recommend against it--it does not handle switching between speakers very well.


    • #3
      My headset works with the default windows sound driver,

      I tried every usb port to install the g.skill headset driver, every time the same issue: "Please connect the g.skill ripjaws sr910"

      and then "g.skill ripjaws sr910 does not exist, the installation program will terminated now"...

      it seems to be an issue with some new windows usb parameters who worked perfectly before...