No announcement yet.

can't boot with F4-3600C18Q-128GTRS-QVL.

  • Filter
  • Time
  • Show
Clear All
new posts

  • can't boot with F4-3600C18Q-128GTRS-QVL.

    I bought F4-3600C18Q-128GTRS-QVL 2 years ago, and I had used them no problem until 2 weeks ago. There was update for Windows10, and I updated, then, automatically rebooted. Since then, it won't boot up. I didn't have any idea why it happened. I tried to re-install windows 10 with bootable usb, and it didn't work. I tried to test ram one by one, and every ram didn't boot up. I had kinston ram 8gbX4 that i used to use. and, They work fine, so it means problem was ram.

    I had no problem for 2 years with F4-3600C18Q-128GTRS-QVL, and I don't understand why it doesn't work now. Please help with me. Thanks,

    Here is my spec.

    Amd Ryzen 5950x
    Asus rog crosshair viii dark hero
    Asus TUF 1070
    980pro 1TB
    Corsair ax850

    G.skill Trident Z royal F4-3600C18Q-128GTRS-QVL(not working now)

  • #2
    DRAM can randomly error and fail over time. Rest assured you are protected by a manufacturer lifetime warranty so you can send them in for inspection and replacement. Submit the G.Skill RMA request form online to initiate the exchange process: