No announcement yet.

Ram created FPS loss

  • Filter
  • Time
  • Show
Clear All
new posts

  • Ram created FPS loss

    I have recently built my first gaming PC and had a major success; I am very pleased with my rig. But then came an upgrade, I purchased more ram to go from 8gb to 16gb and I lost FPS on Battlefield 4 and Rainbow Six Siege. I was getting 100+ on BF4 and 65+ on Rainbow and now both games are averaging 12-14. I want to use the additional ram for Adobe Creative Suite and video rendering but I dont want to lose the FPS while gaming. I am running an ASRock Z170 Pro 4 motherboard with an EVGA GTX 970 FTW gpu. My power supply is a Corsair RM 650. Most importantly I am running the G.Skill Ripjaws V DDR4-2400 CL 15-15-15-35 1.2v Intel XMP 2.0 ready 4Gx2 ram. I read a few forums that said to check voltage / make sure they are running in sync so I raised the voltage from 1.20v to 1.35v (my motherboard wont allow me to go above 1.39v) but it did not fix my issue. BF4 seemed to run fine but eventually dipped back down to 12-15 FPS and Rainbow consistently stayed below 14 FPS. Previously I ran a benchmark and I got a score of 11,000+ but after the ram upgrade my score was less than 4,500. I am new to the PC world and don't want to ruin my rig. I have taken out the two extra ram sticks and my computer is running like it did before. Any and all help will be greatly appreciated!

  • #2
    Do you have the latest BIOS? Did you enable XMP?


    • #3
      I do not overclock because of my unfamiliarity with it and my CPU does not support it... I don't believe it does anyways. I can take snapshots of my BiOS screen but I do believe I have the latest version. I did not enable XMP, I'm assuming you have to do that in order to use 4 sticks of ram?


      • #4
        BIOS version is available in System Information, or you can check in a program like CPUz in Windows.

        Have you tried two modules at a time to see if problem persists? Sounds like a compatibility issue because you should not have such problems.

        If you would like, post some pictures of BIOS and I can take a look to see if everything is correct.


        • #5
          you should make sure you're added 8GB is the same model running at the same speeds and timings as the original 8GB. that is one of good reason to use the XMP profiles.

          you state, "Most importantly I am running the G.Skill Ripjaws V DDR4-2400 CL 15-15-15-35 1.2v Intel XMP 2.0 ready 4Gx2 ram". but your question is about 16GB of RAM. the second kit is another set of these?
          MSI Z97 KRAIT | i7-4790K 4.6GHz \ Thermaltake Water 3.0 Extreme | G.Skill Ripjaws Z DDR3 2400 2x4GB | PCS+ 8GB R9 290X | SSDs: 720GB | HDs: 11TB | beQuiet! Dark Power Pro 11 750w | Anidees AI Crystal | Logitech G600 \ Corsair M95 | G.Skill KM780 RGB (Red) | Corsair Gaming VOID 7.1 | Windows 10 Pro x64 | Lenovo IdeaPad G780