Hello Everyone

The G.Skill Technical forum will be under construction during the month of February. There may be random down time, so we sincerely appreciate your patience and cooperation during this time. We are excited to bring you a more interactive forum to share information. For any technical assistance or issue that may require more attention, please contact us directly via other methods such as email, telephone, social media, NewEgg Chat, and more. Support is available through any avenue you can reach us.

We hope for a quick and smooth transition

Thank you for your understanding

See more
See less

RMA second hand Trident X kit (F3-2400C10Q-16GTX

  • Filter
  • Time
  • Show
Clear All
new posts

  • RMA second hand Trident X kit (F3-2400C10Q-16GTX


    I have purchased a second hand G.Skill Trident X kit (F3-2400C10Q-16GTX) which I had planned to use in my upgrade to an Intel "Haswell" 4770K/Z87.

    I got my Intel 4770K and Z87 motherboard (Gigabyte GA-Z87X-OC) delivered yesterday, installed the CPU and RAM and decided to test it out on an open bench before putting it into my current case.

    With all four sticks in the motherboard it would not POST. It seems to be that only two of the sticks are at issue, I have tried each of the two questionable sticks in each of the 4 memory slots on the motherboard and it will not POST when either of these two sticks installed.

    I have tried resetting the CMOS on the board so it has the default memory settings, applying the XMP profile first with a working stick in then replacing with another stick but it will not POST.

    The other two (working) sticks will POST successfully in any of the 4 slots at both the default 1333mhz speeds and with the XMP profile (2400mhz) applied. Just to be sure, I ran memtest with the two working sticks, they passed with no errors for 2 hours in slots 1 and 2. I took them out and put them in slots 3 and 4 and started memtest again overnight, it was still running this morning when I left for work with no errors.

    So, my question is, can I RMA a second hand RAM kit (no proof of purchase), if yes, is the testing and information provided above enough to warrant an RMA?

    Thank you in advance to anyone for reading this post and (hopefully) replying.

    TLDR: second hand RAM, two sticks don't seem to work. Can I RMA?
    Last edited by shtridentx; 06-04-2013, 05:30 PM.

  • #2
    Dropped GSkill a note to take a look

    Pls offer comments on support I provide, HERE, in order to help me do a better job here:



    • #3

      We are really sorry to hear that you had problem with the RAM, and you can send it back for RMA anytime for the replacement, please go to:
      Our RMA department will issue you a RMA number after received your request.

      Or you can contact the RMA department anytime:

      Thank you


      • #4
        So, I finally just applied for an RMA ( for my G.Skill Trident X kit (F3-2400C10Q-16GTX).

        I've been the two working sticks for the time being, but now I'm using some other RAM so I can RMA the faulty RAM.


        • #5
          ... Ignore...
          Last edited by TOG-TONSCHUH; 03-03-2017, 05:54 AM.