Announcement

Collapse

UNDER CONSTRUCTION: G.Skill Forum

Hello Everyone

The G.Skill Technical forum will be under construction during the month of February. There may be random down time, so we sincerely appreciate your patience and cooperation during this time. We are excited to bring you a more interactive forum to share information. For any technical assistance or issue that may require more attention, please contact us directly via other methods such as email, telephone, social media, NewEgg Chat, and more. Support is available through any avenue you can reach us.

ustech@gskillusa.com
techsupport@gskill.com


We hope for a quick and smooth transition

Thank you for your understanding

GSKILL SUPPORT
See more
See less

Enabling TRIM in Windows 7 with a Phoenix/Phoenix Pro SSD

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    3.2 upgrade

    I upgraded to 3.2 in a minute and Win7 asked me to reboot again.
    I did the regedit for msahci (better late than never)
    My system is:
    - Compaq 610
    - Intel ICH8M SATA AHCI
    - FM-25S2S-120GBP2

    And got low 4K(QD=1) performance... what do you think?

    Sequential Read : 198.657 MB/s
    Sequential Write : 81.716 MB/s
    Random Read 512KB : 193.182 MB/s
    Random Write 512KB : 80.765 MB/s
    Random Read 4KB (QD=1) : 21.516 MB/s [ 5252.9 IOPS]
    Random Write 4KB (QD=1) : 41.669 MB/s [ 10173.1 IOPS]
    Random Read 4KB (QD=32) : 113.181 MB/s [ 27632.0 IOPS]
    Random Write 4KB (QD=32) : 82.444 MB/s [ 20127.8 IOPS]

    Test : 100 MB [C: 28.5% (31.8/111.7 GB)] (x5)
    Date : 2011/01/11 23:03:33
    OS : Windows 7 Home Premium Edition [6.1 Build 7600] (x86)

    Comment


    • #17
      sir do i need to do this on windows 7 ultimate 64?

      Comment


      • #18
        to xSephirothGx

        @xSephirothGx I believe so... doubleclick your drive and check 6.1.7600.16385 version.

        Comment


        • #19
          its 6.1.7600.16385 with 2.1 firmware, so i will need to do this to enable trim?

          I thought windows 7 has trim and by typing the following: fsutil.exe behavior query DisableDeleteNotify
          DisableDeleteNotify=0 means enabled.

          with SSD can i use Deep Freeze? because I plan to use Deep Freeze if it will not degrade my SSD
          Last edited by xSephirothGx; 01-31-2011, 10:49 PM.

          Comment


          • #20
            Hi,
            why we recommend customers register this, because Sand force informed us this information.
            We think they have reason for that.
            Actually I don't think doing this process will affect Deep Freeze or not.

            Comment


            • #21
              Thanks sir ill start this right away.

              Comment


              • #22
                Standard AHCI controller

                I've yet to install my 120gb sniper ssd into my rig but I noticed the standard ahci 1.0 serial ata controller is on driver version 6.1.7601.17514.

                Win7 x64 with SP1
                300gb velociraptor sata2

                Is the updated driver version because of Win7 SP1 or because there isn't an ssd installed?
                If SP1 has anything to do with it then is maximum supported TRIM sectors realized without going through the steps on page 1?

                I guess I can wait till I install the ssd and then check driver version.
                Then go ahead and install sp1 on top of that and check it again.

                I'm just curious if anyone's got any insight on this.
                Thanks much!
                Last edited by taipan; 04-08-2011, 04:53 PM.

                Comment


                • #23
                  confirmed that prior to win7 sp1, the driver version is 6.1.7600.16385. after sp1 update, driver version is 6.1.7601.17514. still unsure if this new driver version supports maximum trim sectors?

                  Comment


                  • #24
                    SSD CRASH AFTER TRIM, Very ODD!

                    I completed the TRIM Regedit and my SSD made a really bad sound after the cold boot! It's the only sound I have heard it make, and I am sure it will be the last! I'm pretty sure it just happened to be that the SSD went the same time after I updated the TRIM. Everything was done properly, read through it 3 times and have been working on computers for years. I did read a post about you guys not to sure what happened if you enable TRIM with the INTEL AHCI drivers installed, but I verified I was using the Microsoft. Would that be possible?? A reg edit blowing up an SSD? I know you can screw to O/S up, but never heard or thought you could kill a SSD or HHD with it! I have only had the Drive installed for about 3 weeks and just finished the time consuming process of transferring all the sys/user folders over the my secondary HDD along with many other tweaks.. Everything was working AMAZING, then BLAM!! Knew instantly it there was a major malfunction!

                    Comment


                    • #25
                      hi SJ,
                      the SSD are using NAND Flash, it should not making sound as you metioned, can your unplug the power to see if the SSD still making any sound or not, and this solution is provide by Sandforce, we are not sure if TRIM will be work by Intel AHCI driver. however, can you erase the SSD by party magic and re-install the firmware to solve this problem?

                      Comment


                      • #26
                        Well, i knew it was strange that the drive would be making any noise at all. It seems like I was wrog about that, also wrong where the noise was coming from. It apears that the SSD somehow was shorting out and causing the CD rom drive to make noise. I had seen somewhere on the GSKILL forum about someone having an issue where if the SSD was touching a certain area, it was causing all of his probelms. I figured what does it hurt to try and make sure the SSD is no touching anything and try and boot it up. Well sure enough, thats what it is! The drive is working like there was nothing wrong with it at all! I removed it from the 5.25 case supplied with it and have it free floating in the case. I defenatly dont like doing this and will be sedning it back to NEWEGG for an RMA, as this drive should not function like this! Also, I am kinda hesitant to upgrade the firmware as my drive seems to be working great. Im going to run some bench marks and see if I need to take additional steps. Let me just lay something out there real quick. If my ATA Controlor in Comp Management is set to STANDARD, not INTEL or Microsoft, do I need to go through Part Magic, update the firmware and enable TRIM? This means a fresh install of the O/S, and I spent over 5 hours today tweeking folders/files settingswhich i was able to get back up. So a fresh install is not looking so nice at this time, but will do if the performance upgrade is there.. Thanks for your help!

                        Comment


                        • #27
                          hi SJ,

                          if you are not using INTEL or Microsoft, it's not necessary to doing these steps, also, new firmware will not raising your performance, it just fixing some compatible issue or some update! if you having good condition with your SSD, you can stay with that without any upgrade.

                          Comment


                          • #28
                            Hi,

                            Thanks for sharing.

                            Regards,
                            Alex

                            Comment

                            Working...
                            X