No announcement yet.

G.Skill Phoenix Blade - Should I be worried?

  • Filter
  • Time
  • Show
Clear All
new posts

  • G.Skill Phoenix Blade - Should I be worried?

    First of all I would like to say that I really like my G.Skill Phoenix Blade. The performance blows me away even after 2 months use.

    Here is my issue:
    I have bought a Phoenix Blade in November and installed it in my i7 3820, Sabertooth X79 PC. It's in the last slot of the MB with system installed on it. Recentely I have been doing alot of video encoding and thus leaving my computer on for extended periods of time and started getting BSODs (the PhoenixB was not involved in the video encoding data I/O). I started digging and noticed that my computer often simply would freeze with the HDD I/O light on continuosely. In my case it seemed as parts of the Blade were not acessible by the system. Opening a Control Panel, for example, would show the window but not all the icons would refresh, showing the white default icon instead. The explorer would then freeze leaving no possibility to restart/ctrl+alt+del or anything. The mouse would still move though. I tried to schedule CHKDSK on the Blade and it would offten freeze about midway during the 4th verification step (verifying file data) about halfway through the step. The activity light on the blade would suddentely go blank and the HDD i/o light on the case would flash continuousely.

    I have since managed to get my computer running by doing the erase action from the gskill ssd tool and reinstalling. Everything seems to be working again and HD Tune reports no errors on the surface and Aida64 reports solid 2gb/s random read....

    Having those issues I tried to search whether other ppl were having the same issues and I've stumbled upon this thread :
    On post number 16# an overclockers UK staffer says that Phoenix Blades have an astounding 67% RMA rate and that they stopped offering them on their site because of that.

    Can anyone from G.Skill please comment on the issue I was having, and the fact that Overclockers seem to have such high RMA rate? I live in Switzerland and most retailers stock the other SSDs but not the Phoenix Blade. Is there something wrong with the product? Should I RMA mine? Is this something that can be fixed with an firmware upgrade? I was about to order 10 Phoenix Blades for our developer PCs at work, however I am sligtly worried now so I'll hold the upgrade untill this can be clarified.



  • #2
    I'm not sure where they got their information. Do they work for G.Skill? Since release, I have only seen 2 come back here at the USA office. There is no issue with the product; in fact it works great for Win7/8. As long as the card is configured correctly, you should have no problems.


    • #3
      Thanks for the reply, exactely what I was hoping for.




      • #4
        I have the same issue as MMoudry. Longer time running like +48 hours - high risk that the card stop its work. Its impossible to use the win8 feature "fast boot". When i disable CSM i get the error "The system cannot find the UEFI driver for the add-on storage devices". I tried my old harddrive, no issue. Also when i try to boot the ssd form the boot menu "Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key".
        I am disappointed and I might send the SSD back...


        • #5
          Been through 2 RMA with newegg, they seem to have pulled it off inventory and its marked no refund.... was told any further issues they can't help anymore have to contact g.skill. I would prolly think twice about purchasing the phoenix blade.

          Also... G.Skill PCIe SSD Tool 1.0, fails to update firmware. Firmware update failed (error=-2)

          Has there been an update to the program or a way to manually flash?


          • #6

            still no update to the tool error?