No announcement yet.

Phoenix Pro drives

  • Filter
  • Time
  • Show
Clear All
new posts

  • Phoenix Pro drives

    Back in 2010 I got my self 2 120 Phoenix Pro drives I got about 2 years out of them before they started to drop out and not be picked up by bios on any computer with any cords at this point I changed to Samsung and never looked back. Now the other day when i was cleaning up I came a cross these drives again and just for interest stake I tossed them in my HTPC, They didn't work.

    So as I had nothing better to do I decided to open one up and have a look everything looked ok so I was thinking maybe ill plug it in and see. IT worked so I did the same to the other one and it worked as well............... I have been running them on a glass table for about 24h now and have had no issues with these drive at all. I must point out I tried everything to get these drives to work with no luck.

    Don't try this at home unless your ready to rubbish bin these drives as I was

  • #2
    I have the same problem, my SSD started to be not detected by bios before the en of the 3 years warranty. I thought it was because of the incompatibility between haswell and SF 1200. But even in a USB3 enclosure, there were more and more detection problems.

    GSkill just answered me I won't have any RMA for this SSD, even if I reported this problem in time.

    Now they are useless (as you say, ready for the bin).
    So I am very interested in what you did. Just open and close the SSD would do the job ?
    Have you tried to power off and on your computer several times ? Everything is ok ?

    Thanks for your message (a new hope) and your help.


    • #3
      All I have done is remove them from the steel cases I now have them suspended in my HTPC and they appear happy. Don't let them contact anything that could earth them out when powered