Hello Everyone

The G.Skill Technical forum will be under construction during the month of February. There may be random down time, so we sincerely appreciate your patience and cooperation during this time. We are excited to bring you a more interactive forum to share information. For any technical assistance or issue that may require more attention, please contact us directly via other methods such as email, telephone, social media, NewEgg Chat, and more. Support is available through any avenue you can reach us.

We hope for a quick and smooth transition

Thank you for your understanding

See more
See less

FM-25S2S-120GBP2 dissapears from everywhere, even from BIOS

  • Filter
  • Time
  • Show
Clear All
new posts

  • FM-25S2S-120GBP2 dissapears from everywhere, even from BIOS


    I have a SSD unit FM-25S2S-120GBP2.

    It was working fine since I bought it, more than a year ago.

    My PC information:

    Motherboard: ASUS P8H61-M PRO
    BIOS: 4602 (latest)
    CPU: INTEL CORE i5-2500K
    RAM: 8 GB DDR3 (1333 MHz)
    Hard disk 1: FM-25S2S-120GBP2 (only for system) with lates firmware.
    Hard disk 2: Western Digital Caviar Green 1 TB (WDC WD10EADS-00L5 B 1)

    OS: Windows 7 Ultimate 64 bits fully updated (until I formated).

    Yesterday, it started to freeze minutes after I turn on the PC.

    I tried some things and then, I erase all partition and formated the FM-25S2S-120GBP2.

    It started OK. I installed all drivers OK.

    But then, it started to freeze again. Just a few minutes after I turn on PC.

    I tried to format and install again but I couldn't. Win 7 install fails with message like "It can't find the file".

    First, it fails after copying the installation files to HDD. In the part it must expand the files.

    Then, It started to fail without finishing the part of copying files to HDD.

    I changed FM-25S2S-120GBP2 to another SATA port.

    What I found:

    Minutes after I turn on the PC, the FM-25S2S-120GBP2 dissapears. Not only from Windows. It dissapears even from BIOS. And the HDD led in the case keeps on forever.

    I reboot the PC with the reset button, but boot process stops in the part it should list the HDD's in screen and the HDD led keeps on.

    I have to shut down the PC with power-on button, and turn it on again. That way, FM-25S2S-120GBP2 appears again in BIOS. But again, a few minutes and it's gone.

    It also happens with Hiren's boot mini Windows XP. You see the FM-25S2S-120GBP2 and can "navigate" it. And sudenly, an error window saying something like "it can't find the unit" and the disk is gone.

    I use PC for work only, and all my data is in the Western Digital 1 TB disk and backed up in a NAS unit.

    But I need to know if my FM-25S2S-120GBP2 is dead, to start to re-organize the WD disk to install windows there.

    PC is fully protected with UPS and voltage stabilizer so I don't think it could be any voltage problem.

    Any help, will be very welcome.

    Thanks in advance.

  • #2

    please kindly try the secure erase by Parted Magic(sticky thread) and re-install firmware, it could help you correct the issue as well.


    • #3
      Originally posted by GSKILL View Post

      please kindly try the secure erase by Parted Magic(sticky thread) and re-install firmware, it could help you correct the issue as well.
      Well... I can tray.

      But, how can I do the secure erase when it could take between 30 and 180 minutes, and my disk dissapears three / five minutes after I turn on my PC?

      I tested the disk as USB disk (using an USB HD adapter) and it does the same. Five minutes after I connected to another PC's USB port, and it's gone.

      As I said, I'll try and let you know the results.

      Thank you.


      • #4

        Just want to inform that I tried to perform a Low Level Format using the HDD Low Level Format tool version 4.25 ( and it fails everytime around 4%.

        It stops and HDD Low Level Format tool doesn't respond. But, when I remove the SSD it responds again.

        I'm downloading Parted Magic to try secure erase.

        I'll let you know.


        • #5
          Parted Magic Secure Erase didn't work


          I tried the secure erase with Parted MAgic, but, as I expected, it didn't work.

          SSD dissapears before I can just start the erase.

          Don't know what to do.

          The SSD has in it's label the manufacture date April 2011. It has less than 2 years. And I bought it months after April 2011.

          Any idea what to do?


          • #6
            Nothing works


            After try all I could, nothing works:

            * I connected SSD to SATA 1 port.
            * I set AHCI mode in BIOS
            * I booted with Parted Magic CD and did the secure erase as is explained in this forum.
            * Secure erase ends a few seconds after it starts. Not even a minute. No error message.

            Then disk stops responding and I can't do the secure erase again.

            I also tried to re-install firmware 4.2A. It ends and PC reboot.

            But again, disk stop responding.

            So, don't know what to do next. ?RMA?

            As I said, disk has 3 years warranty and it was manufactured in April 2011.

            Please, explain me how should I do the RMA procedure from Argentina.

            Thank you.


            • #7

              please kindly contact our RMA department:

              and you can check all the RMA information at here:

              sorry for the inconvenient!


              • #8
                My SSD came to life


                Almost a year since I opened the thread.

                I want to inform that my SSD is working now.


                After a thousand reboots and plug and unplug SSD, my PC detected it. I flashed firmware 4.0

                If you remember, I was using firmware 4.2

                So, I downgraded to 4.0

                And, it works fine now.

                Hope you could use this info. Maybe something is wrong with 4.2 firmware.

                My SSD came with 4.0 when I bought it. After I updated it, it failed. And now, it came to life again.

                I've created parition, I copied a DVD image into it. Full speed. No problem.

                I'll keep playing with it. Testing. Maybe I install a clean copy of Windows 8 to see behavior.

                Anything you need, just ask.

                Question 1: why firmware 4.0 package is 169.193 KB and 4.2 is only 39.819 KB?

                Question 2: what's the difference between firmware 4.0 and 4.2?

                Best regards.


                • #9

                  Not sure why the firmware 4.0 is smaller, but as the Sandforece datasheet mentioned, the 4.2 is enhance the compatibility/performance of the SSD.

                  And really appreciate about your using experience, please kindly PM us and we will send you some goodies.


                  • #10
                    Originally posted by GSKILL View Post

                    Not sure why the firmware 4.0 is smaller, but as the Sandforece datasheet mentioned, the 4.2 is enhance the compatibility/performance of the SSD.

                    And really appreciate about your using experience, please kindly PM us and we will send you some goodies.

                    Thanks for your reply.

                    In fact, firmware 4.0 is bigger than 4.2.

                    We're not talking about a few KB.

                    We're talking about a difference around 130 MB. Don't know how a SSD needs 170 MB of software to work and, sudenly, the same SSD needs only 40 MB of software. Where did the other 130 MB go to? Why SSD doesn't need them anymore?

                    Until now, SSD is still working fine. I didn't install any SO in it because I'm trying to install in UEFI mode and I couldn't do it. But that's just a different story.

                    Best regards.


                    • #11
                      Hi again

                      Just want to update the thread.

                      My SSD "died" again.

                      As I said, SSD came back to life when I downgraded to firmware 4.0.

                      I partitioned it OK. Formated it OK.

                      I copied many files to it.

                      It was working plugged to sata last few days.

                      Today, I decided to install a fresh copy of Windows 8 Pro 64 bits in UEFI mode.

                      So, I seted up BIOS, started installation.

                      Three partitions for UEFI installations where created. THe installation continued.

                      After firts reboot, bang!!!! SSD wasn't there.

                      UEFI BIOS never detected it again. No matter how many reboots, how many plug and unplug.

                      SSD is gone. Not working in sata nor with USB adapter.

                      So, I guess I must ask for RMA number and send it to California.

                      Best regards.


                      • #12
                        Hi again

                        Sorry to bother you again.

                        But my replacement SSD (RMA UR2135931) just died last night same way the "original" one.

                        I turned off my PC perfectly.

                        When I turned it on, it said "Bootmanger is missing".

                        After check in UEFI BIOS, found that SSD "wasn't" there. I mean, it was plugged because it wasn't touched. The only steps were:

                        * Turn off PC correctly
                        * Turn on PC one hour later.
                        * Message "Bootmanager is missing".
                        * SSD is not there for PC.

                        I plugged a standard HD (for emergencies), reinstalled Windows 10 and PC is running fine after a few minutes.

                        My question is: is my replacement SSD covered by warranty? Do I have to send it again to RMA?

                        See, sending it is very very expensive from Argentina. And I already did it once. If you check, receive the new SSD is a problem too. In fact, the first replacement never arrived and you had to send another from Taiwan.

                        The other thing: in GSkill forum, the latest firmware for my SSD model is 4.2. But my replacement SSD came with newer one (I think 4.3). Where can I download this newer version to try to flash it?

                        Hope for your soon reply.

                        Best regards.