Got a technical problem?

Please provide the following information with any new post involving a technical issue with your G.Skill peripheral. This pertinent information will allow us to effectively troubleshoot and provide the best solution.

1) Software (SW) version and firmware (FW) version
2) Did this issue occur on a new software installation or software update?
3) What is the model number of your keyboard and layout? (e.g. KM780 RGB, NA English; etc.)
4) Which Windows OS version are you using? (e.g. Windows 7 Ultimate 64-bit; Windows 10 Pro 64-bit; etc.)
5) Which USB port did you plug the keyboard into? (e.g. USB3.0 in motherboard back panel, USB2.0 hub, etc.)
6) Your motherboard model number
7) Any antivirus/anti-malware software programs you have installed
8) Any other keyboard/mouse/similar device software you have installed

If you would like, you can also email this info to for our peripherals team to troubleshoot/replicate the issue.

Thank you!
See more
See less

Can't open driver interface.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't open driver interface.

    Well I have been trying to get the user interface for the driver/software open but I can't do it. Every time I click on the icon I get a loading icon on the mouse pointer for a second but then nothing. I have sense tried the mouse on both my laptop and pc both running Windows 10 64-bit and has never run. I did get it to work when I was in safe mode on my pc. I also tried installing it as administrator in save mode and running it as admin with no change.

    After trying it on two different systems I don't think its any program I have installed blocking it. And the only programs that I have installed that could interfere (however unlikely) would be 7-zip, Chrome, and Windows Defender. To rule out any interference from Windows Defender I disabled real time protection and any other settings I could, again no change.

    This leads me to believe that something Windows itself is doing something to block the program from starting. The driver is running as a background process (its 32 bit version too). So at this point I'm completely stuck and I don't know what else to rule out. So some help here would be appreciated.