Announcement

Collapse

Got a technical problem?

Please provide the following information with any new post involving a technical issue with your G.Skill peripheral. This pertinent information will allow us to effectively troubleshoot and provide the best solution.

1) Software (SW) version and firmware (FW) version
2) Did this issue occur on a new software installation or software update?
3) What is the model number of your keyboard and layout? (e.g. KM780 RGB, NA English; etc.)
4) Which Windows OS version are you using? (e.g. Windows 7 Ultimate 64-bit; Windows 10 Pro 64-bit; etc.)
5) Which USB port did you plug the keyboard into? (e.g. USB3.0 in motherboard back panel, USB2.0 hub, etc.)
6) Your motherboard model number
7) Any antivirus/anti-malware software programs you have installed
8) Any other keyboard/mouse/similar device software you have installed

If you would like, you can also email this info to techsupport@gskill.com for our peripherals team to troubleshoot/replicate the issue.

Thank you!
See more
See less

MX780 installation problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MX780 installation problem

    Hello,

    I am having some problems installing the software for the MX780 Gaming Mouse. I did some research first, and was unable to find a solution so I’m hoping that you can help me out.

    Here’s my issue: at the end of the installation, the installer launches the firmware update tool and goes no further. The firmware update tool appears on my screen as an empty grey box (screenshot in attachment). I tried installing the software in safe mode (suggested by a forum user) and it did the same thing. I let the firmware update tool “run” for about an hour thinking that maybe it was working, and the UI was not rendering, but that was not the case. If I close the firmware updater by right-clicking the taskbar icon and selecting close, the software will boot up but it will not actually make any changes to the mouse. I can change the lighting profiles and save them, but the led lights on the mouse do not change with the profiles.

    Edit: I am attempting to install the latest software version 0.78 with firmware 21.

    My system:
    Windows 10 home edition 64 bit
    MSI Z170 Gaming M7 motherboard
    Intel Core i7 6700k cpu
    32GB DDR4 2400mhz Avexir RAM
    MSI Radeon R9 390x graphics card

    I also have the KM780 RGB Mechanical Keyboard with cherry mx red switches, and it’s software functions perfectly. However, if I click the “update” button in the settings window, then the same empty firmware update tool appears.

    Hopefully this is a known issue, and the solution is simple. Thank you in advance for you time and assistance.
    Attached Files
    Last edited by Mr. Jack; 01-10-2017, 05:36 PM. Reason: adding information

  • #2
    First, we'd like to make sure whether or not the firmware update has completed its job, or if the firmware update got cut off in the middle. To do this, please click the wrench icon in the top right corner and let us know the firmware and software number it displays.

    Second, it would be great if you could re-download the installer package, unzip it to the desktop, and then run the installer to uninstall and install the software with administrator rights (by right clicking on the installer and choosing to "Run as Admin"). And see if the same issue occurs. (The firmware update will not have any action if the firmware number is the same.)

    If the same issue occurs, try going to C:\Program Files (x86)\G.Skill\G.SKILL RIPJAWS MX780\FWUpdate folder and running the included *.exe file with admin rights. A small window will display and disappear if the version is already updated. If the firmware is not current, then there should be a red bar that shows the progress.

    The firmware updater should complete in no more than 3 minutes. Any longer means something is preventing the updater from closing.


    TL;DR - Use admin rights to install and run when installing or updating. If the version is already current, then the firmware updater will automatically close.


    In regards to the mouse lighting issue, it might be a mismatched firmware and software issue. We can help further if you can provide the firmware and software version that's currently running.

    Thanks!
    Last edited by G.SKILL; 01-10-2017, 09:55 PM. Reason: Fixed grammar.

    Comment


    • #3
      I redownloaded the installer and ran it as an administrator, and the same issue occurred. The firmware updater showed a blank gray window, so I let it run for about 5 minutes before forcing it closed.

      The "wrench" icon shows Firmware version to be 0, and software version to be 0.78. When I click on check update, the same empty firmware update tool appears.
      Attached Files

      Comment


      • #4
        The issue has been resolved. On a whim, I decided to turn the motherboards "hotkey" function off. I didn't really have a reason...but I tried everything else that I could think of. But it seems like that is what was causing the problem. I'm not sure why though, since the mouse was not plugged into the hotkey port (the keyboard is), but the firmware now shows version 21 and the software functions normally.

        Comment


        • #5
          Excellent to hear! We were only aware that some ASUS motherboards had direct hotkey settings, and didn't know MSI added hotkey features too.

          The hotkey function is essentially controlled and monitored by an extra layer (e.g. extra chip) between typical communciation between the OS/motherboard and the keyboard, often monitoring or filtering signals. It might have prevented the firmware update signals from getting through to the keyboard. We've seen similar cases on some motherboard models, just not MSI until now.

          Thanks for letting us know.

          Comment

          Working...
          X