Announcement

Collapse

Got a technical problem?

Please provide the following information with any new post involving a technical issue with your G.Skill peripheral. This pertinent information will allow us to effectively troubleshoot and provide the best solution.

1) Software (SW) version and firmware (FW) version
2) Did this issue occur on a new software installation or software update?
3) What is the model number of your keyboard and layout? (e.g. KM780 RGB, NA English; etc.)
4) Which Windows OS version are you using? (e.g. Windows 7 Ultimate 64-bit; Windows 10 Pro 64-bit; etc.)
5) Which USB port did you plug the keyboard into? (e.g. USB3.0 in motherboard back panel, USB2.0 hub, etc.)
6) Your motherboard model number
7) Any antivirus/anti-malware software programs you have installed
8) Any other keyboard/mouse/similar device software you have installed

If you would like, you can also email this info to techsupport@gskill.com for our peripherals team to troubleshoot/replicate the issue.

Thank you!
See more
See less

[SW2.03] The software still requires .NET Framework 3.5 to be preinstalled

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SW2.03] The software still requires .NET Framework 3.5 to be preinstalled

    ^As I said^ the software still requires .NET Framework 3.5 to be preinstalled.

    Yes, I'm using the latest version SW2.03 / FW76 for my KM780 RGB (German), I'm running Win10 Pro x64.

    Without .NET Framework 3.5 the software won't launch properly, causing it to crash after the loading bar, installing it AND reinstalling the software resolved this problem.

    Originally posted by G.SKILL View Post
    Hi jjxaker,

    You've got it. Check out version 2.00 for KM780 RGB. MS .NET Framework is no longer required.

    We're rolling out the rewrites in the coming months to our other keyboards, so check back if you've got our other keyboard models.
    ^This seems to be false information^
Working...
X