Announcement

Collapse

Got a technical problem?

Please provide the following information with any new post involving a technical issue with your G.Skill peripheral. This pertinent information will allow us to effectively troubleshoot and provide the best solution.

1) Software (SW) version and firmware (FW) version
2) Did this issue occur on a new software installation or software update?
3) What is the model number of your keyboard and layout? (e.g. KM780 RGB, NA English; etc.)
4) Which Windows OS version are you using? (e.g. Windows 7 Ultimate 64-bit; Windows 10 Pro 64-bit; etc.)
5) Which USB port did you plug the keyboard into? (e.g. USB3.0 in motherboard back panel, USB2.0 hub, etc.)
6) Your motherboard model number
7) Any antivirus/anti-malware software programs you have installed
8) Any other keyboard/mouse/similar device software you have installed

If you would like, you can also email this info to techsupport@gskill.com for our peripherals team to troubleshoot/replicate the issue.

Thank you!
See more
See less

KM570 (Red LED) - LEDs only work on startup?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • KM570 (Red LED) - LEDs only work on startup?

    I'm having an issue with my KM570 Red LED (not RGB) keyboard. The LEDs only seem to work if the keyboard is plugged in on start up. If I unplug the USB cable and then plug it back in, none of the LEDs work. Note, this ONLY happens on Mac OSX, which I know is not officially supported but there's no software so it should just be plug and play. The RGB version works fine in the above scenarios and the RED version works fine on Windows and Linux when unplugging and plugging back in. I've got around it by a) Either restarting or b) Loading a windows VM in virtual box . Does anybody have any insight on why this may be happening?

    Firmware version 21.
    Model KM570 (RED Leds) MX Brown switches.
Working...
X