1 of 2 < >


Hello Everyone

The G.Skill Technical forum will be under construction during the month of February. There may be random down time, so we sincerely appreciate your patience and cooperation during this time. We are excited to bring you a more interactive forum to share information. For any technical assistance or issue that may require more attention, please contact us directly via other methods such as email, telephone, social media, NewEgg Chat, and more. Support is available through any avenue you can reach us.

We hope for a quick and smooth transition

Thank you for your understanding

2 of 2 < >

Got a technical problem?

Please provide the following information with any new post involving a technical issue with your G.Skill peripheral. This pertinent information will allow us to effectively troubleshoot and provide the best solution.

1) Software (SW) version and firmware (FW) version
2) Did this issue occur on a new software installation or software update?
3) What is the model number of your keyboard and layout? (e.g. KM780 RGB, NA English; etc.)
4) Which Windows OS version are you using? (e.g. Windows 7 Ultimate 64-bit; Windows 10 Pro 64-bit; etc.)
5) Which USB port did you plug the keyboard into? (e.g. USB3.0 in motherboard back panel, USB2.0 hub, etc.)
6) Your motherboard model number
7) Any antivirus/anti-malware software programs you have installed
8) Any other keyboard/mouse/similar device software you have installed

If you would like, you can also email this info to for our peripherals team to troubleshoot/replicate the issue.

Thank you!
See more
See less

[BUG] KM780 Management application does no more run after a while

  • Filter
  • Time
  • Show
Clear All
new posts

  • [BUG] KM780 Management application does no more run after a while

    I have this problem really frequently, since the begining : I install the management application (App.exe), with administrator privileges (right-click, run as admin), because when I install it normally (double-click) it asks for administrator privileges, I accept and type the admin password, it seems intalling correctly, but after the installation, it simply doesn't run (1st bug).

    2nd bug, after installing it by running App with admin privileges, App runs, with admin privileges request (wich seems to me a bit abused) and I can configure my keyboard. But after some days, when I want to make some configuration changes, App requests for admin privileges, but doesn't run anymore, without any notice or error message, even in the windows event console. It simply doesn't start. I've checked, whitout any modification, the application ran only once with a true administrator session.

    I have to uninstall and reinstall the manager to fix the problem.
    This is about the tenth time I reinstall it, nearly for each configuration change, and each time I loose some parts of the configuration (mainly lightning), and this is really ennoying

    I'm using a Windows 10 Pro 64 PC, up to date, with all windows updates installed, and using App v0.91 (the latest for KM780 AFIK).

    Please try to fix this problem, if you need more feedback, maybe I can help. But ATM, I really don't know what more to say, because I don't have a bit of information concerning this problem.

    And last, you should provide an option to change the installation folder (maybe with an advance mode), cause I'm trying to keep my little system SSD as clean as possible, and I would've been happy to install it in D:\Program Files(x86)

    Ty for help

    Edit : This workaround was totally unhelpfull
    Last edited by Mosquito25; 04-18-2017, 06:17 PM. Reason: Title edition

  • #2
    I did some more tests.
    It seems your software is pure ******** : I've installed it using a true admininstrator session, as a result, it doesn't run in a non-administrator session with privileges elevation. WTF?.

    So I uninstalled and reinstalled it once more, using my usual session, in administrator mode, by right-click, run as administrator. As a result, App.exe starts (I'll try later to check if it's run once only, and I'll edit)

    I'M OUT OF PATIENCE, SPENT 4H to have this shitty program to run

    Obviously, you need to engage some better windows system programmers, maybe I could send you a CV

    And last, I've totally lost all of my configuration, not only lightnings, but also macros

    [EDIT] Cheked once again, it seems App runs only once.
    Last edited by Mosquito25; 04-09-2017, 09:00 AM.


    • #3

      Still having the problem, and today, even game profiles don't work, so no macros, and no lightning layout in game


      • #4
        We'd like to make sure that we're understanding your issue correctly. The software can only be opened once, after installation? And this is for the KM780 MX (single color red LED)? Or does the software disappear after going into sleep mode and cannot be opened after wake?

        It would be helpful to us if we also have the following information:
        1. What's the language of Windows 10, 64-bit installation?
        2. What's the firmware of the keyboard? (This can be found in the wrench icon on the upper right corner)
        3. What's the full part number listed in the back panel of the keyboard? (should start with "GK-")
        4. What's your motherboard model number?
        5. Has the BIOS been updated lately? What's the current BIOS version you are using?
        6. Which ports are the keyboard USB connectors connected to?

        Also, in regards to usage, did you click "Save to Device Memory" after changing settings in the software?

        Last edited by G.SKILL; 04-16-2017, 06:46 PM. Reason: added a sixth question


        • #5
          Ty for your awnser.

          My configuration :
          1 : Windows 10 Pro 64 bits, version 1607, Operating System version : 14393.1066, French language
          2 : Firmware 29, App version 0.91
          3 : P/N GK-K8R1C2-KM780S10FR (M/N : Ripjaws KM780 MX, S/N : 1605GK00009281)
          4 : Motherboard : ASUS P8Z68-V PRO GEN3, Bios version 3802
          5 : No, BIOS wasn't updated recently, it's an old motherboard, and this is the latest bios update (2015/04/07), don't remember exactly when I installed it, but at least 1 year ago.
          6 : USB-2, on an external Belkin 7 ports USB Hub, with dedicated power supply. But the keyboard never loses the USB connection. And IMHO, this is non an USB problem, but I checked using another hub, got exactly the same problem.
          Obviously, I use a non administrator user account.

          To be completely clear about the problem, I've made some more tests, and spent 4 more hours.

          1st I've checked if the program could start, it couldn't.
          So I unistalled it, restarted my computer, and reinstalled using right-click, run as admin. App automatically starts at then end, ok.

          I've made some profile modifications (and exported them), and checked (without closing app), all was ok, profile switching, macros, lights.
          I closed App, and tried many time to restart it, it was ok ONLY USING RIGHT-CLICK run as administrator. Otherwise nothing happens.
          1st bug, all the links you create (start menu and desktop) do not require administrator privileges, so they do not work.

          Then I closed and reopened the window session, and effectively, App didn't run anymore. Worst, profile switching (linked applications) didn't work either.

          So I tried again this workaround, again it didn't work. And if I read correctly, the purpose of this workaround is to start App at each logon and worstation unlock, this is really not what I want. I don't need to have permanently App on my screen.
          I've restarted windows, tried, and App still doesn't run.

          Last I've powered off my computer, waited 5 minutes before powering back on. App still doesn't run.

          So the problem is App stops functionning after log off/session lock/power off FOREVER

          At last, to be sure this is not an USB problem, I've repeated ALL THE TESTS on another usb hub, using 2 ports working all day long without a kind of problem with exactly the same result, APP STOPS FONCTIONNING FOREVER after logoff/workstation lock/shutdown, and don't run EVEN AFTER A HARD BOOT.

          So the only way I have to make some profile changes after a logoff or workstation lock is :
          1 - Uninstall Gskill App
          2 - Reinstall GSkill App
          3 - Import the profile and the macros to be changed
          4 - Do the changes
          5 - Save & Export the modified profile and macros

          And as profile switching doesn't work after logoff/workstation lock/shutdown, I can use ONLY ONE profile, otherwise I have to unistall, reinstall, import all macros and profiles, and save all profiles to keyboard again.

          And really, admin privileges to run this program? Are you serious? I understand you need this to update the keyboard memory profiles, but maybe a background task with admin privileges to do this part of job, but not for the UI.

          Lol, I've just notice that the default export directory is Users\Superuser\Desktop. You're kidding? Icons on the desktop LMFAO

          Last bug : if you install the software using a non admin session without right-clicking, run as admin (i.e. using double-click, open, or Enter key), the installation program seems running fine, but App doesn't start at the end of the installation, and starts neither using the links, even using run as adminstrator.

          I hope you'll solve this problem quickly, but maybe I'm dreaming? You're avare of the problem since 2016, August, 9 month ago, and still nothing.

          When I started to write this reply, I wanted to be calm, but as the tests progress and seeing all these problems, I must say that I am in a black anger again.
          Last edited by Mosquito25; 04-18-2017, 08:27 AM.


          • #6
            Double post
            Last edited by Mosquito25; 04-18-2017, 06:23 PM. Reason: Double post


            • #7
              Ok, I think I found the real cause of the problem.

              Your application is monolithic, and you start it using a key in HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Curr entVersion\Run.
              As a result, at logon App is started using the user account, AND MINE IS NOT ADMINISTRATOR.

              As I said in my previous post, installation can't launch the UI when started using double-click. Installer requests admin privileges, but fails to open the UI, probably because app is started with current account (didn't check this). The only way to make it run correctly is to right-click and run as administrator. In this case, App is run with the superuser account, and everything runs fine until logoff/workstation lock/sshutdown.

              But at next logon/workstation unlock, App restarts, but using the user account, not administrator, and UI fails to open.

              Last edited by Mosquito25; 04-18-2017, 10:18 AM.


              • #8
                Ok, I've found a first workaround : I just removed the Ripjaws key in HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Curr entVersion\Run, so App simply doesn't start.
                I start App once as administrator, and the program runs in background, and profile switching works.
                I just need to restart it as administrator to get the UI.

                It works, but it's really crappy

                And your workaround is simply useslesss on my windows, because app runs in background, no need to restart it.
                The true problem is app runing using a non administrator account.
                I've tried to set the task user as MyPC\SuperUser but there are errors in the TaskScheduler event log, saying session failed to open. It seems it is security policy related. I've also tried to add SuperUser in Local Security Policy -> Local Policies -> User Rights Assignment -> Log On As Batch Job, but it didn't work, the errors still occur.

                I stop now, been busy on this problem for 7h today.

                Guys, I'm REALLY ANGRY. Did you program this **** for Windows 3.1 or Windows 95?

                YOU NEED TO SEPARATE UI wich doesn't need administrator privileges from PC<->Keyboard communication, wich needs them, and should even be a Windows service.
                Last edited by Mosquito25; 04-18-2017, 06:58 PM.


                • #9
                  If you don't awnser before tuesday, I'll put a negative advice on all e-merchant sites where I'm registered, explaining my (the) problem, including a link to this thread.


                  • #10
                    Hi Mosquito25,

                    Thank you for your feedback and explaining the issue.

                    Regarding the software application closing upon logoff is something that will be fixed in an updated software revision, but will be rolling out for the KM780 RGB keyboard in the beginning of May. The KM780 MX will follow with the same fix toward the end of May.

                    Due to the major rewrite of this next version, it has taken us some time to release. Thank you for your understanding and patience.


                    • #11
                      Ok, thanks for your reply, I understand this is a major rewrite and need some time to achieve. So I will not put this negative advice, just a tip with the current problem and my workaround (can be helpfull for other customer playing with non administrator account).
                      And also explaining you've planned a corrective patch in may
                      Last edited by Mosquito25; 04-24-2017, 09:15 AM.


                      • #12
                        Originally posted by G.SKILL View Post
                        Regarding the software application closing upon logoff is something that will be fixed in an updated software revision, but will be rolling out for the KM780 RGB keyboard in the beginning of May. The KM780 MX will follow with the same fix toward the end of May.
                        The date for RGB version is exceeded by a whole month, and still nothing.
                        You're sleeping?


                        • #13
                          Sorry about that. We've run into a delay, and the new version is going through a final polish stage with some more bugs to fix, and has been rescheduled for a release on the week of the 19th. The MX version will be following in 4 weeks after that.

                          We are truly sorry about the delayed release. It's important to us to fix as many bugs as possible with this refresh update.


                          • #14
                            Originally posted by G.SKILL View Post
                            Sorry about that. We've run into a delay, and the new version is going through a final polish stage with some more bugs to fix, and has been rescheduled for a release on the week of the 19th. The MX version will be following in 4 weeks after that.

                            We are truly sorry about the delayed release. It's important to us to fix as many bugs as possible with this refresh update.
                            Wich century?