Announcement

Collapse
No announcement yet.

RGB not working on one stick

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RGB not working on one stick

    Hello,

    Before starting, this is the reference of the product : G.Skill F4-3000C15D-16GTZR (2x8Go)

    and my config :
    i7 8700k
    MSI Z370 Gaming Pro Carbon
    MSI 1080Ti Gaming X 11G
    NZXT Kraken X62

    So, last week, RGB on one of the stick stopped working. I was booting up my PC as usual when I saw that one stick wasn't lighting up.

    Both RAM modules are detected and working.
    Both RAM modules are detected in G.Skill RGB, but one is not working.

    I did everything I found on this forum, but nothing worked.

    -RAM are in DIMMA2 and DIMMB2 slots by default, and switching them in DIMMA1 and DIMMB1 lead to the same result
    -Tried with gameboost ON/OFF and XMP ON/OFF
    -Dowloaded Taiphoon, and CRC is OK on both RAM modules
    -Tried clean unistall / install
    -Tried cut off power for 3min, open G.Skill program, and set ON/OFF the lights 3 times
    -Not working with MSI Mystic light (only 1 stick)

    Just a note, when I switched the RAM modules, I couldn't open G.Skill RGB anymore, I had the error :
    "No G.Skill Trident Z RGB DRAM module(s) found on your computer system! Program will be terminated"
    To solve that, I had tu put the RGB RAM module that was working ALONE in the computer, boot it, open G.Skill RGB, and then shut down the computer to put back the second stick.

    Thanks

  • #2
    Have same issue, except one of the ram losing RED light, no software install just default rainbow.
    Not all the red light, only on 1 area only...

    Comment

    Working...
    X