No announcement yet.

No control on Asrock x399 board with AMD version RAM

  • Filter
  • Time
  • Show
Clear All
new posts

  • No control on Asrock x399 board with AMD version RAM

    So far I have had no luck in controlling the RGB of the F4-3200C14Q-32GTZRX. The most recent version of the software (1.00.28) fails to detect any of the modules and then must be closed.

    This is on an Asrock Taichi X399 board with an AMD Threadripper 1950x. Prior to this board, i was able to control the colors of the same ram on my prior board (Gigabyte X370 Gaming K7) with no issues so I know the ram works. (I have also verified that there are no SPD issues with Thaiphoon Burner).

    Is this an Asrock bios issue, or a G.Skill software issue? Any similar situations or help would be appreciated.

    Thank you.

  • #2
    Did you try this?


    • #3
      Yeah, i have done two installations. The first installation i had turned UAC off, and that check box isn't in the properties window. The more recent installation I left UAC on, and the check was there, however checking it to "unblock" made no difference. When i launch the program it still says it cannot detect any compatible memory and must close.


      • #4
        Do you have the latest BIOS for the motherboard?

        Check to see if SPD Write is enabled in BIOS.


        • #5
          Yes, have the latest bios for the motherboard. 2.0 is the latest. I have looked for this setting in the bios after reading about other motherboards. I am not sure this exists on the Asrock X399 Taichi. I have looked through all the settings and have not been able to find anything about SPD write. Could it be called something else in the bios?


          • #6
            Just want to thow out there that I am having the same issues with control of this ram.

            Same Processor, MB and RAM.
            I am currently on BIOS 1.80.

            I have tried multiple configurations and various BIOS settings to no avail.
            The current system was a 100% fresh install of windows 10 with NO other software installed but the G.Skill software, to no avail.

            I will support troubleshooting when I am not away for business.


            • #7
              Contact the RGB team directly to see if there is any specific set up for this hardware combination



              • #8
                Confirmed that I am unable to control the modules if they are in the motherboard (Asrock x399 Taichi) recommended slots of A2, B2, C2, D2. However, If i move the modules to A1, B1, C1, D1, the software detects the modules and controls them perfectly. However the motherboard will only boot at the default speed of the ram (2133 mhz instead of the XMP2.0 speeds of 3200 mhz). Plus the timings are more loose in the #1 slots.

                So it definitely has something to do with the slots used on the motherboard.

                At this time, the control of the modules is not as important me as the speed of the ram, so I will be moving the modules back to the recommended slots and await a solution from G.Skill / Asrock.


                • #9
                  Provide the feedback to AsRock and G.Skill RGB team, hopefully the next updates can resolve any issue.


                  • #10
                    Thanks, I have let the Techsupport team know via email. I just wanted other users to have the information as well.


                    • #11
                      Just wanted to say that I have the same issue. Contacted support as well.


                      • #12
                        If you're having trouble with 4 modules of Trident Z RGB on the ASRock X399 Taichi motherboard, please run through the checklist below and make sure you've got everything. On our test system with the ASRock X399 Taichi motherboard with BIOS 2.00 and in Windows 1709, the software detects the modules and is able to run lighting effects, but there may be a specific setup configuration or setting that's causing the no-detect issue.

                        - Before doing any of these steps, please make sure to uninstall the software by using the *.exe file. And that the modules are in slots A2, B2, C2, D2.

                        - When the system is turned off, at the very top edge of the motherboard, there is a switch labeled "MOS_PROCHOT1" near the 8-pin power connector. Please make sure this is set to "ON".

                        - Please reset your BIOS by doing the following:
                        1. Power off your system, and unplug the power cable
                        2. Press the CLRC_BTN1 a couple of times on the bottom of the motherboard, next to the power/reset button
                        3. Plug in the power, and boot. BIOS should be reset to defaults now.

                        - After booting into Windows, make sure that there are no unidentified or unknown devices in "Device Manager". If there are unknown devices, right click and choose to update the driver. Then with the "search online" option, most system-related drivers can be found.

                        - Before extracting the installation folder, make sure to "unblock" the zip file before extracting. For extracting, try opening the ZIP file using the Windows Explorer and drag it out of the compressed folder/file.

                        - Before installing, make sure to execute the installer with admin rights by right clicking on the *.exe file and choose to "Run as admin".

                        - After installation, restart, and on the next boot, open Task Manager and go to the "Services" tab, and find "LightingService". Right click on this and choose to "Restart" the service.

                        - Now try open the software, and see if it still gives you the "not detected" error message.

                        - If the software still doesn't open, please open task manager, and go to the Services tab. With the Trident Z RGB software is installed, please check if "asComSvc" (description is "ASUS Com Service") is present and is running.

                        If there are any other error messages, feel free to report it here, as there may be other causes.


                        • #13
                          Has the above worked for anybody with the X399 Taichi and RGB? Unfortunately, it has not worked for me. I still cannot control the RGB.


                          • #14
                            It didn't work for me either...


                            • #15
                              I think that is the support that we can expect from GSkill...You can only access and modify the colors on GSkills Trident Z ram only in slots A1, B1 and so goes on. However, when in slots A2, B2, etc RGB cannot be detected by the software, in this no RGB adjustment. ram is stuck on rainbows and unicorn farts for colors.
                              Of course not using the 'x'2 banks disrupt the system quad channel and stability.
                              Can we get an update that can fix this recurrent issue with mothers that use a different banking order for the ram?
                              Last edited by djmaxi; 02-23-2018, 04:59 AM.