Announcement

Collapse

UNDER CONSTRUCTION: G.Skill Forum

Hello Everyone

The G.Skill Technical forum will be under construction during the month of February. There may be random down time, so we sincerely appreciate your patience and cooperation during this time. We are excited to bring you a more interactive forum to share information. For any technical assistance or issue that may require more attention, please contact us directly via other methods such as email, telephone, social media, NewEgg Chat, and more. Support is available through any avenue you can reach us.

ustech@gskillusa.com
techsupport@gskill.com


We hope for a quick and smooth transition

Thank you for your understanding

GSKILL SUPPORT
See more
See less

How to enable SPD Write on Asrock Motherboard

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to enable SPD Write on Asrock Motherboard

    yes ive read your instructions, well i cant find any "SPD Write" enable options on my motherboard: Asrock Z270 Extreme4

    1.00.08 = works, i can control my trident z rgb
    1.00.16 = works, i can control my trident z rgb
    1.00.22 = doesnt work
    1.00.28 = doesnt work, software cant run

    and yes i know how to completely remove your software and clean install your software.
    and yes i know how to follow your instructions

    and yes, my mobo bios is updated. stop treating us like retards, we know how to update






    Intel i5 6600K @ 4.5GHz 1.36v 53c Max Temp
    Asrock Z270 Extreme4
    16GB Trident Z RGB 3000MHz
    Galax GTX 1070 Hall Of Fame
    Seasonic Prime Titanium 650W
    ID Cooling Frostflow 240L-W

  • #2
    Which two memory slots do you have the memory modules installed in? Can you try switching to the other two slots?

    And can you PM us with the serial numbers of your modules? This will help us check if there are any other issues that might be happening. Thanks.

    Comment


    • #3
      Originally posted by G.SKILL View Post
      Which two memory slots do you have the memory modules installed in? Can you try switching to the other two slots?

      And can you PM us with the serial numbers of your modules? This will help us check if there are any other issues that might be happening. Thanks.
      ofcourse i tried slot 1 and 3..
      and the other slot 2 and 4..
      i also tried turning off my computer and psu, and drain the power first.

      it still says "please reboot the system to complete the installation"

      using an Asrock Z270 Extreme4 mobo, bios version 2.20 (latest)

      heres my modules
      Last edited by botee; 12-02-2017, 05:07 PM.
      Intel i5 6600K @ 4.5GHz 1.36v 53c Max Temp
      Asrock Z270 Extreme4
      16GB Trident Z RGB 3000MHz
      Galax GTX 1070 Hall Of Fame
      Seasonic Prime Titanium 650W
      ID Cooling Frostflow 240L-W

      Comment


      • #4
        same issue here.

        Comment


        • #5
          OS?

          What OS are either of you two using? Windows 10 was interfering with my installation until I tweaked some things prior to installation.

          Comment


          • #6
            Windows 10



            Pretty sure that Serial # shouldn't be blank.
            What did you tweak to get it work. None of the software versions will work now

            Comment


            • #7
              Method

              Copy/Pasting from a previous thread:

              "This may not help you, but I was able to get around the issue of RAM not being detected on version 1.00.28 on Windows 10. Maybe it won't work for you, but since I've done this it has worked fine for me.

              1. Download the zipped v1.00.28 installation files from the support page (do NOT extract yet)
              2. Navigate to the folder where you saved the zipped folder. Right click on the folder and open up Properties
              3. In the General tab of the Properties window, the last section of the tab is the Attributes section. In here, look for a checkbox that is labeled "Unblock". If such a checkbox is not present, then unfortunately my fix won't work for you. However, if the box is there, check it then click "Apply". Once you've done that, click "Okay" to close the Properties window. If you want to be extra safe, re-open the Properties window and verify that the "Unblock" checkbox is now gone.
              4. Proceed to extract the files from the zipped folder as you would normally, then install. When I next ran the software, it was able to detect my RAM and I was able to control the LEDs

              IMPORTANT NOTES:
              1. As you've probably seen elsewhere, I do not recommend using other LED control software simultaneously with the G.Skill software. I personally am using a Gigabyte board with RGB Fusion, and I can simply open up task manager and force kill the application there before running the G.Skill software to control the RAM. Once I'm done, I can then use task manager to kill the "LightingService" task and then reopen RGB Fusion if I need to. ASUS Aura might be fine but I don't know anything about that, personally.
              2. Unfortunately, one or two of the sticks can forget its/their setting(s) when the PC powers on after a shutdown or restart. This can be easily resolved by just opening up the G.Skill software and re-applying the settings. Again, if you're using another LED control software package, you should probably kill that process as described above before attempting to reset the RAM lighting."

              This appears to have worked for one other person beside me. Hopefully it works for you, too!

              Comment


              • #8
                Originally posted by WeAreDormin View Post
                Copy/Pasting from a previous thread:

                "This may not help you, but I was able to get around the issue of RAM not being detected on version 1.00.28 on Windows 10. Maybe it won't work for you, but since I've done this it has worked fine for me.

                1. Download the zipped v1.00.28 installation files from the support page (do NOT extract yet)
                2. Navigate to the folder where you saved the zipped folder. Right click on the folder and open up Properties
                3. In the General tab of the Properties window, the last section of the tab is the Attributes section. In here, look for a checkbox that is labeled "Unblock". If such a checkbox is not present, then unfortunately my fix won't work for you. However, if the box is there, check it then click "Apply". Once you've done that, click "Okay" to close the Properties window. If you want to be extra safe, re-open the Properties window and verify that the "Unblock" checkbox is now gone.
                4. Proceed to extract the files from the zipped folder as you would normally, then install. When I next ran the software, it was able to detect my RAM and I was able to control the LEDs

                IMPORTANT NOTES:
                1. As you've probably seen elsewhere, I do not recommend using other LED control software simultaneously with the G.Skill software. I personally am using a Gigabyte board with RGB Fusion, and I can simply open up task manager and force kill the application there before running the G.Skill software to control the RAM. Once I'm done, I can then use task manager to kill the "LightingService" task and then reopen RGB Fusion if I need to. ASUS Aura might be fine but I don't know anything about that, personally.
                2. Unfortunately, one or two of the sticks can forget its/their setting(s) when the PC powers on after a shutdown or restart. This can be easily resolved by just opening up the G.Skill software and re-applying the settings. Again, if you're using another LED control software package, you should probably kill that process as described above before attempting to reset the RAM lighting."

                This appears to have worked for one other person beside me. Hopefully it works for you, too!

                thanks for the help. it still didnt helped my, i did the check the "unblock" thingy

                i noticed that something was loading on my startup when i saw it on my controlled startup software. looks like related to the gskill software.

                can anyone explain this to me..
                Intel i5 6600K @ 4.5GHz 1.36v 53c Max Temp
                Asrock Z270 Extreme4
                16GB Trident Z RGB 3000MHz
                Galax GTX 1070 Hall Of Fame
                Seasonic Prime Titanium 650W
                ID Cooling Frostflow 240L-W

                Comment


                • #9
                  Hi botee,

                  This registry entry appears after an installation, and should be gone after a reboot. Did you reboot the system after the installation?

                  Also, which software is that? We'd like to try it out if possible to see if it's interfering with the software installation and operation. Thanks!

                  Comment


                  • #10
                    Originally posted by G.SKILL View Post
                    Hi botee,

                    This registry entry appears after an installation, and should be gone after a reboot. Did you reboot the system after the installation?

                    Also, which software is that? We'd like to try it out if possible to see if it's interfering with the software installation and operation. Thanks!

                    bro, ofcourse if willl reboot after installation. i can follow simple instructins. if it says reboot ill reboot. but that prompt still appears after reboot.

                    i used http://www.greatis.com/bootracer/ software, i monitors how fast my system boots
                    Intel i5 6600K @ 4.5GHz 1.36v 53c Max Temp
                    Asrock Z270 Extreme4
                    16GB Trident Z RGB 3000MHz
                    Galax GTX 1070 Hall Of Fame
                    Seasonic Prime Titanium 650W
                    ID Cooling Frostflow 240L-W

                    Comment


                    • #11
                      We've checked through our test system and that registry entry you see is just an action that deletes the flag that tells you to reboot after the installation. After a reboot, that registry entry should disappear (because it'll only run once), and the flag should be gone.

                      One of your monitoring programs probably is preventing that action to be successfully activated after the reboot, so if you're having problems with starting the software, it's probably because the software still sees that flag so it won't start.

                      The solution is to let that action run its course, or you can delete the flag yourself. Just open Regedit, and go to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ASUS\AURA and delete the "needReboot" entry. And we're seeing a second entry, which is under Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\A SUS\AURA, and delete "needReboot" in there as well.

                      After deleting this flag, and then after a reboot, this should let your software start up correctly.

                      And to remove the command for the deletion, search for "DelNeedReboot" (it may also have one with a number behind "DelNeedReboot") located under HKEY_LOCAL_MACHINE\Software\...\Microsoft\Windows\ CurrentVersion\RunOnce.


                      Edit Recap (to make things easier):

                      Look for four places to look in the registry and delete the entries. If it's not there any more, then you can skip it.

                      Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ASUS\AURA\nee dReboot
                      Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\A SUS\AURA\needReboot
                      Computer\HKEY_LOCAL_MACHINE\Software\Wow6432Node\M icrosoft\Windows\CurrentVersion\RunOnce\DelNeedReb oot
                      Computer\HKEY_LOCAL_MACHINE\Software\Wow6432Node\M icrosoft\Windows\CurrentVersion\RunOnce\DelNeedReb oot6432
                      Last edited by G.SKILL; 12-28-2017, 12:01 AM. Reason: Added a recap to make locating the entries easier.

                      Comment


                      • #12
                        Originally posted by G.SKILL View Post
                        We've checked through our test system and that registry entry you see is just an action that deletes the flag that tells you to reboot after the installation. After a reboot, that registry entry should disappear (because it'll only run once), and the flag should be gone.

                        One of your monitoring programs probably is preventing that action to be successfully activated after the reboot, so if you're having problems with starting the software, it's probably because the software still sees that flag so it won't start.

                        The solution is to let that action run its course, or you can delete the flag yourself. Just open Regedit, and go to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ASUS\AURA and delete the "needReboot" entry. And we're seeing a second entry, which is under Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\A SUS\AURA, and delete "needReboot" in there as well.

                        After deleting this flag, and then after a reboot, this should let your software start up correctly.

                        And to remove the command for the deletion, search for "DelNeedReboot" (it may also have one with a number behind "DelNeedReboot") located under HKEY_LOCAL_MACHINE\Software\...\Microsoft\Windows\ CurrentVersion\RunOnce.


                        Edit Recap (to make things easier):

                        Look for four places to look in the registry and delete the entries. If it's not there any more, then you can skip it.

                        Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ASUS\AURA\nee dReboot
                        Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\A SUS\AURA\needReboot
                        Computer\HKEY_LOCAL_MACHINE\Software\Wow6432Node\M icrosoft\Windows\CurrentVersion\RunOnce\DelNeedReb oot
                        Computer\HKEY_LOCAL_MACHINE\Software\Wow6432Node\M icrosoft\Windows\CurrentVersion\RunOnce\DelNeedReb oot6432
                        in the four directories, i found the "DelNeedReboot" here at Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\A SUS\AURA\needReboot
                        i deleted it and rebooted my computer. tried running 1.00.28 again.. It now starts and i can now use it.

                        thanks! pls try to include this deletion thingy properly in your installation.

                        THANKS AGAIN FOR THE HELP. gonna share this with mah friends
                        Intel i5 6600K @ 4.5GHz 1.36v 53c Max Temp
                        Asrock Z270 Extreme4
                        16GB Trident Z RGB 3000MHz
                        Galax GTX 1070 Hall Of Fame
                        Seasonic Prime Titanium 650W
                        ID Cooling Frostflow 240L-W

                        Comment


                        • #13
                          I have the exact same board, and can't get these sticks to work for the life of me. I've tried every solution that has been posted, and suggested here. This is what I can confirm about my Asrock board, and Gskill RGB.

                          DIMM's in Slots A1,A2 (single channel) - Software works fine, and I can control the RGB.
                          DIMM's in Slots A2,B2 (dual channel) - No modules detected. This is the preferred setup for dual channel memory when using only 2 modules per Asrock's Manual.
                          DIMM's in Slots BI,B2 - same as A1/A2
                          DIMM's in Slots A1,B1 (dual channel) - For some reason, this setup works with the Gskill software where the modules are detected, and I can change colors. The problem is my Asrock board doesn't like this configuration in which my system either boot loops, or stays at default settings. It won't let me save my XMP, or my CPU overclock.

                          I have the latest BIOS installed 2.30. I even contacted Asrock about this, and of course they said this is on Gskill's end. Gskill, and Asrock need to communicate better to get their stuff to work. Memory prices are insane right now, and I'm not gonna buy another kit just to get some RGB colors to change.

                          Comment


                          • #14
                            Originally posted by Rammer View Post
                            I have the exact same board, and can't get these sticks to work for the life of me. I've tried every solution that has been posted, and suggested here. This is what I can confirm about my Asrock board, and Gskill RGB.

                            DIMM's in Slots A1,A2 (single channel) - Software works fine, and I can control the RGB.
                            DIMM's in Slots A2,B2 (dual channel) - No modules detected. This is the preferred setup for dual channel memory when using only 2 modules per Asrock's Manual.
                            DIMM's in Slots BI,B2 - same as A1/A2
                            DIMM's in Slots A1,B1 (dual channel) - For some reason, this setup works with the Gskill software where the modules are detected, and I can change colors. The problem is my Asrock board doesn't like this configuration in which my system either boot loops, or stays at default settings. It won't let me save my XMP, or my CPU overclock.

                            I have the latest BIOS installed 2.30. I even contacted Asrock about this, and of course they said this is on Gskill's end. Gskill, and Asrock need to communicate better to get their stuff to work. Memory prices are insane right now, and I'm not gonna buy another kit just to get some RGB colors to change.
                            if you only have 2sticks of rams, the rams can be detected in slot A1 + B1
                            Intel i5 6600K @ 4.5GHz 1.36v 53c Max Temp
                            Asrock Z270 Extreme4
                            16GB Trident Z RGB 3000MHz
                            Galax GTX 1070 Hall Of Fame
                            Seasonic Prime Titanium 650W
                            ID Cooling Frostflow 240L-W

                            Comment


                            • #15
                              Are you asking, or saying? In my previous post, I mentioned that using only slots A1 + B1, the sticks are detected, and the software works fine. It's just that Asrock doesn't like that config with 2 RAM sticks, and my system doesn't work right.

                              Comment

                              Working...
                              X