Announcement

Collapse
No announcement yet.

[Trident Z RGB Software BETA] Enabling Trident Z RGB Lighting Control on ASUS X99

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Trident Z RGB Software BETA] Enabling Trident Z RGB Lighting Control on ASUS X99

    Introduction
    In order to allow and enable Trident Z RGB lighting control on X99 motherboards, a “DRAM SPD Write” function must be enabled. By default, ASUS X99 motherboards have this set to “Disabled”, so we will have to enable this function to use the Trident Z RGB software. At the time of writing, Gigabyte, MSI, and ASRock X99 motherboards have this option enabled by default.

    Note: For best results, please make sure BIOS is updated to the latest version.

    Instructions
    1. Enter BIOS. (Press the “DELETE” key while the system is booting to enter BIOS.)
    2. Check and make sure you are in the “Advanced Mode”. (If you are in the “EZ Mode”, press the “F7” key to switch to the “Advanced Mode” menu.)
    3. Navigate to the “Ai Tweaker” tab.
    4. Scroll down to find “DRAM Timing Control” and press “Enter”.
    5. Scroll all the way down to the bottom inside the “DRAM Timing Control” menu, and you will see a “DRAM SPD Write” option.
    6. Press “Enter” or “Page Up/Down” to select “Enable”.
    7. Press “F10” key to save and exit the BIOS.
    8. After rebooting into the Windows OS, the Trident Z RGB software should be able to detect the memory modules and allow you to set lighting effects.




  • #2
    Nice!

    thanks for getting this worked out and will have to try it out when I get home!

    Comment


    • #3
      can confirm this works on my X99 Rampage V Extreme (although im liking the default colour scheme)

      now if i can only get XMP to work

      Comment


      • #4
        X99 Gaming?

        I tried this on my X99 gaming mb - in the RGB Control Software, the 2x8 rgb showed finally up but I was only able to adjust one of them. Using Asus Aura, none of them was recognized at all. And as stated in the guide, both tools are incompatible with each other (rgb control killed aura completely or aura overwrote the latter's content). Did I miss something here or will there be an update for this compatibility issue?

        Comment

        Working...
        X