Announcement

Collapse
No announcement yet.

[Trident Z RGB Software BETA] Known Issues

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Tucubanito07,

    I asked about the RMA location just to check if we could find a clue on the replacement kit. But if it's through a local retailer and not directly with G.SKILL, we wouldn't be able to get reliable info on the replacement process.

    If the IC chips are identified as different, then there's something wrong. You might want to email rma@gskill.com with your country name. We'll try to help you get it sorted out. Please also say that you're from the forum, with your username. Thanks.

    And regarding the lighting, the software does store "static", "breathing", and "strobing" effects to the lighting module, so it'll light up the same way the next time the system boots. But this will likely get removed in a future revision. If you press "Default", it will go back to the default rainbow wave after you shut down and start again.

    Comment


    • #17
      I have the Gigabyte GA-AB350-Gaming 3 motherboard with F6 version bios. I'm using the free avast antivirus and I have the SKU F4-3000C15D-16GTZR memory kit.

      Comment


      • #18
        Originally posted by G.SKILL View Post
        Tucubanito07,

        I asked about the RMA location just to check if we could find a clue on the replacement kit. But if it's through a local retailer and not directly with G.SKILL, we wouldn't be able to get reliable info on the replacement process.

        If the IC chips are identified as different, then there's something wrong. You might want to email rma@gskill.com with your country name. We'll try to help you get it sorted out. Please also say that you're from the forum, with your username. Thanks.

        And regarding the lighting, the software does store "static", "breathing", and "strobing" effects to the lighting module, so it'll light up the same way the next time the system boots. But this will likely get removed in a future revision. If you press "Default", it will go back to the default rainbow wave after you shut down and start again.
        Email the RMA dept again. Really. I have done everything that a customer has to do to get this fix. Still haven't. By the way I did the RMA process with that same email and your website. I bought the ram from newegg and i never tried with them because the RMA process is with you guys. Also, I have spent money after money to get this fixed and now you want me to RMA this again. The RMA number is UR2171555. Have them ship me an envelope with the right ram stick and I'll send you these back. I even told the RMA dept to put a hold on my credit card and they said no. I'm really tired of sending this back and forth wasting my hard earned money for a company that I bought their product that does not work. They have my email if you want to talk in private.

        Comment


        • #19
          I'm down to 2 of 4 DIMMs staying lit.

          Other than swapping the order of the modules what else can I try?

          I lost the lighting from the 2 DIMMs closest to the CPU.

          Comment


          • #20
            after installing the software; when I restarted one of the sticks is now dark!!! man, this RAM is such a headache. I'm giving up on trying to get these stupid things to work. these sticks don't even boot @ 2600Mhz!

            Comment


            • #21
              I swapped my modules around and still only had 2 lit (now the 2 nearest the CPU). The I opened the software and checked the box for OFF, then ON, OFF, ON, DEFAULT, OFF, ON, and one of the dark ones lit up.

              However I still cannot get the first one that went dark to light up.

              LED's don't burn out this quick, is this the fault of the software?

              Comment


              • #22
                yep. mine is dark as well. it happened when I installed the software. one stick will not come back on. tried switching, unplugging, reinstalled the broken software....etc. I am really upset that these are so bad.

                Comment


                • #23
                  Any ETA on new software version Asus or g Skill?

                  I returned my 16gb kit (one module went dark and would not come back on) and bought a 32gb kit F4-3600C16Q-32GTZR but I am afraid to install the new kit.
                  I have uninstalled the Asus software (using Asus Maximus IX Formula w/ most recent bios 0906). Would I be okay to install the ram and just not install the software until customers are finished beta testing for g skill?

                  As much as I absolutely hate the default rainbow setting! Default should have been white led's only Anyway what should I do, im starting to think I should have rebought DDR4 without LED's.
                  Last edited by sdmf74; 05-23-2017, 11:02 AM.

                  Comment


                  • #24
                    I have an ASUS VIII GENE Z170 and have the G.Skill 3600Mhz TridentZ RGB CL16 kit (8GB x2).
                    DIMM_A2 and B2 are populated. Experienced the issue whereby DIMM_A2 would sometimes go dark. Also CPU-Z/HWMonitor would freeze with "Mutex Locked" error. In order to correct this I would:

                    1. Close CPU-Z/HWMonitor
                    2. Open G.Skill RGB software and select "LED OFF" setting (RGB program freezes)
                    3. Click the 'X' button to close the G.Skill RGB software
                    4. Reboot PC into Desktop
                    5. Open G.Skill RGB software and select "DEFAULT" (nothing happens)
                    6. Click the 'X' button to close the G.Skill RGB software
                    7. Reboot PC into Desktop
                    8. Wait 1-2 minutes and both DIMM_A2 and B2 now have "Rainbow" effect

                    Now waiting for the "RC" version of G.Skill RGB software
                    Last edited by MRPC; 05-23-2017, 01:01 PM.

                    Comment


                    • #25
                      Good news everyone. I updated to the latest version of the control app and my rgb lights started working again. Unfortunately not 100%. One of the sticks works great but the other is quite dark compared to it.

                      Comment


                      • #26
                        With the new .22 beta my dark stick lit up but I had to install the software twice, however the program is much more delayed and my sticks aren't responding to any lighting adjustments.

                        Comment


                        • #27
                          Trident Z RGB not Lighting up after 1.00.22 update

                          This is extremely aggravating. Before the update my RGB is perfectly fine. After updating it wont light up it wont even let me in the software. Getting error "no g.skill trident z rgb dram module found on computer". I've tried every fix that you are currently recommending including reseating modules. Updating BIOS. Doing a clean uninstall of the software, trying different dimm slots, uninstalling other RGB software. It still wont light up and I still cannot get into the software. This is frustrating to the point that I want my money back. We paid a good amount to have this RGB ram of yours but we are getting no response when we email your tech team. FIX THIS!!! this type of after sales service is very poor. And just so you know my mother board is completely compatible with my Trident Z RGB. here's my current system..

                          Asrock Z270 extreme 4 updated to the latest BIOS
                          Intel i5-7600k
                          Trident Z RGB 3000 2x8gb

                          Comment


                          • #28
                            3 out of 4 of my sticks went dark. When I run the G.Skill app it says no g.skill ram detected and won't open.

                            AMD Ryzen 7, 1800x processessor
                            Gigabyte Gaming K7 motherboard x370
                            G.Skill Trident Z RGB 2400 4x8gb
                            Kraken 62x Liquid Cooler
                            Windows 10 Pro, Creator's Update

                            I have APP CENTER installed, for my motherboard features. Within that is a controller for FUSION motherboard lights. I turned them all off, and I turned APP CENTER off from startup to see if that fixed any conflicts. Nothing. I couldn't get my Kraken to light up without CAM, however I turned that off too for the same reason. No change. My PC recognizes the RAM as G.Skill ram in overclocking apps, but not the G.Skill app. I've checked and there is no service running called asLEDwhatever or anything that contains LED at all. I'm at a loss!

                            I returned the first set for the same issue. Sadly, my system looks worse with 1/4 glowing sticks than it would without any glowing ram at all. I tried changing slots. I don't know what else to do.

                            Please help!

                            Comment


                            • #29
                              PandaMan,

                              send your information to techsupport@gskill.com and they can help right away.

                              Which slots are you using? Have you tried the other slots?

                              Did you have any other RGB lighting software installed? Test each to see if one can work normally.

                              MREMTFF,

                              At this time, only one RGB lighting software can be used or conflicts may occur.

                              If you must use other RGB software, it may be best to wait for an update.
                              To revert back to default rainbow, end all RGB lighting software, swap modules around, and see if the software can recognize the modules.

                              Comment


                              • #30
                                Originally posted by MREMTFF View Post
                                3 out of 4 of my sticks went dark. When I run the G.Skill app it says no g.skill ram detected and won't open.

                                AMD Ryzen 7, 1800x processessor
                                Gigabyte Gaming K7 motherboard x370
                                G.Skill Trident Z RGB 2400 4x8gb
                                Kraken 62x Liquid Cooler
                                Windows 10 Pro, Creator's Update

                                I have APP CENTER installed, for my motherboard features. Within that is a controller for FUSION motherboard lights. I turned them all off, and I turned APP CENTER off from startup to see if that fixed any conflicts. Nothing. I couldn't get my Kraken to light up without CAM, however I turned that off too for the same reason. No change. My PC recognizes the RAM as G.Skill ram in overclocking apps, but not the G.Skill app. I've checked and there is no service running called asLEDwhatever or anything that contains LED at all. I'm at a loss!

                                I returned the first set for the same issue. Sadly, my system looks worse with 1/4 glowing sticks than it would without any glowing ram at all. I tried changing slots. I don't know what else to do.

                                Please help!
                                You gotta try and use Taiphoon burner to restore the SPD BRO!

                                I have no idea why the GSKILL TECHS wont tell people the real fix but my 2 dark sticks are lit back up and fully functional after.

                                I trouble shot on the forums, even sent in my system stats and GSKILL never was of any help to me.

                                I swapped sticks like 20 times and even re seated my CPU do to a memory error just to find out from Google that it was corrupt SPD...
                                Last edited by HeroCrusher; 06-07-2017, 03:12 PM.

                                Comment

                                Working...
                                X