Announcement

Collapse

UNDER CONSTRUCTION: G.Skill Forum

Hello Everyone

The G.Skill Technical forum will be under construction during the month of February. There may be random down time, so we sincerely appreciate your patience and cooperation during this time. We are excited to bring you a more interactive forum to share information. For any technical assistance or issue that may require more attention, please contact us directly via other methods such as email, telephone, social media, NewEgg Chat, and more. Support is available through any avenue you can reach us.

ustech@gskillusa.com
techsupport@gskill.com


We hope for a quick and smooth transition

Thank you for your understanding

GSKILL SUPPORT
See more
See less

[Trident Z RGB Software BETA] Known Issues

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    the Slots are marked with a1, a2 ,b1, b2... and the modules are (now) as wanted in the Slots marked with 2 so every 2nd Slot. and as you say the nearest Slot of each side is empty.
    but the 2 new modules worked also in the 1 Slots.

    Comment


    • #92
      Originally posted by kuLLe View Post
      I recently updated my Gigabyte AX370-Gaming 5 to the latest BIOS Version F10. My G.Skill Trident Z DRAM Modules F4-3200C14-8GTZR always worked like a charm on this board, well except the first versions. With the F10 BIOS still Frequency speed @ 3200 so everything fine. Anyhow, when looking into my case I found out that the LEDs of my G.Skills were OFF. Tried a lot of stuff and found that you simply need to power off your computer and cut the power supply for a certain time so the caps will be unloaded as well. I made a coffee so came back around 2 minutes later. Afterwards I had the default rainbow effect again. Nice, thought the new G.Skill v1.00.28 will work now, but nope: „No G.Skill Trident Z RGB DRAM module(s) found on your computer system“ error message showed up. Tried a lot of things but nothing could fix it (Deinstall, Reinstall all versions[v1.00.16, v1.00.22], reinstalled windows, deactivated the Logitech Gaming services, …). What really was the issue that the TridentZ_RGB_v1.00.28.zip file is coming from an unknown source(?) so Windows 10 will not unzip it properly (At least what my thoughts are here). I would guess this guide will work for any other Hardware combinations as the problems seems to be the file handling in windows. So ASUS, MSI, ASRock and other MB vendors should work as well.

      My solution:

      1) If the modules are completely dark, power off computer, cut power supply for a couple of seconds (To be safe 2 mins?)
      2) Afterwards you should have the rainbow effect again
      3) If the modules are not recognized by the G.SKILL Trident Z Control Software and you get the „No G.Skill Trident Z RGB DRAM module(s) found on your computer system“ message do this:
      3a) Uninstall the Software
      3b) Delete the AXSP and the IO folder within the ASUS folder in you programs(x86) folder and the LightingService folder.
      4) Restart your computer
      5) Now download the TridentZ_RGB_v1.00.28.zip
      6) Do not unzip the files! Right click on the .zip and go to Properties
      7) Now in General check the unblock checkbox. After clicking on it the box is gone and the zip will be trusted.
      8) Now unzip and install. After the restart of the system you hopefully have control of your DRAM’s LEDs again.

      Hope that helped.
      I can't thank you enough for this. On my new build using a ASRock Z370 Extreme4 board, I had the default rainbow effect and was having issues getting the program to even run. Followed your instructions and works as expected now. I'll have to remember this for future installs, just to prevent something similar from happening. Thanks again!

      Comment

      Working...
      X