Announcement

Collapse
No announcement yet.

Post your issues with the Trident RGB Control software here

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hello everyone. I've had issues with this software for a while now. It would work great then break, then work, then break... and now, I'm stuck.

    The last thing I remember happening is the software not detecting the ram sticks at all. I was trying to uninstall everything and reinstall the software but I got stuck here and I'm still stick at this point:

    https://i.imgur.com/XH83m1f.gifv

    So what is happening is I run setup.exe and it tries to uninstall the previous software before installing the new stuff but it is just stuck in this uninstallation loop. I've tried many things including a "clean install", many reboots, installing the beta files and the new version files...

    I'm not sure what else to try here. I would love to get this ram working.

    Thanks

    Comment


    • Originally posted by JoeBlobs View Post
      Hello everyone. I've had issues with this software for a while now. It would work great then break, then work, then break... and now, I'm stuck.

      The last thing I remember happening is the software not detecting the ram sticks at all. I was trying to uninstall everything and reinstall the software but I got stuck here and I'm still stick at this point:

      https://i.imgur.com/XH83m1f.gifv

      So what is happening is I run setup.exe and it tries to uninstall the previous software before installing the new stuff but it is just stuck in this uninstallation loop. I've tried many things including a "clean install", many reboots, installing the beta files and the new version files...

      I'm not sure what else to try here. I would love to get this ram working.

      Thanks
      Download revo uninstaller and run an unistall through revo. After the uninstall is complete it will ask you if u want to clear registry keys etc. Do that aswell and then it should install properly

      Comment


      • Originally posted by mouraklanis View Post

        Download revo uninstaller and run an unistall through revo. After the uninstall is complete it will ask you if u want to clear registry keys etc. Do that aswell and then it should install properly
        Awesome now we are making progress. Thank you sir. After installation and reboot I now get a crash when I run the beta software. Before anything launches. I tried admin mode, doesn't work.

        Aaaaand... now all of a sudden it does work??? Haha this software is crazy.

        Thank you again for your help mouraklanis. I figured it was a registry thing but didn't know where to start. That seems like a nice program to just have.

        Welp, we'll see how long this fix lasts.

        Comment


        • Before I complete the RMA form, is there any chance I can send only the stick with the dead LED and keep the other one so my computer isn't useless for days? I kinda need it...
          There was a time that one of my sticks was causing my computer to not be able to boot and GSKILL accepted that request, but I fixed it and never sent it to RMA, now it's just the LED, my computer can detect all 16gb of my ram. Thank you!

          SPECS:
          Ryzen 7 1700
          MSI MORTAR ARCTIC B350M
          TRIDENTZ RGB 8GBx2 (16GB)
          ASUS STRIX GTX 970
          SAMSUNG EVO SSD 250GB
          WD 1TB HDD
          CORSAIR RM750X PSU

          Comment


          • GMuttz,

            Best to send in the complete kit, because each kit is tested to ensure that each module is compatible with each other and working perfectly as a kit. You can submit your RMA request, then ask the RMA team that issued your RMA number for more details on the RMA process and to ask how long the RMA might take from your location.

            Comment


            • Well, I got my RMA replacement kit a couple weeks back. Same issues still. Can't detect modules in the preferred Dual Channel slots, but works fine in Single Channel mode. So either my MB is not right, or like many of the other posts I'v read, the Gskill Software just doesn't play nice with non ASUS motherboards. Asrock support is pretty adamant that it's non on their hands even with the latest BIOS updates. At this point since everything runs fine, I'll just stick with the rainbow effect, and let it be. I'll just spend a few extra bucks on a ASUS board next time just to make sure RGB RAM will work right.

              Comment


              • Are they ever going to update this software? My modules always desync over time with color cycle and default.

                Comment


                • sometimes i can open up my trident z rgb controller software, sometimes i cannot.

                  it says "trident z rgb modules detected"
                  Intel i5 6600K @ 4.5GHz 1.36v 53c Max Temp
                  Asrock Z270 Extreme4
                  16GB Trident Z RGB 3000MHz
                  Galax GTX 1070 Hall Of Fame
                  Seasonic Prime Titanium 650W
                  ID Cooling Frostflow 240L-W

                  Comment


                  • I'm also having an issue with my G.SKILL TridentZ RGB Series 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600) Desktop Memory Model F4-3200C16D-16GTZR.

                    I have a Gigabyte Z370 Aorus Gaming 7 motherboard and not only can I not control the RGB with the Gigabyte Software, this memory frequently (as in every other day) will freeze up, and remain unresponsive to commands within it's own G.Skill RGB software with the only solution being full shutting down the PC and turning off the PSU / disconnecting power. I need to be able to turn the RGB off in the evening as the illumination is very bright but the only way to do so is to completely turn off the PC, then restart, then turn off the RGB within the software, then shut it back down again. This is unacceptable.

                    I've already uninstalled and reinstalled your G.Skill software multiple times. The problem persists.

                    I bought this memory under the impression that it would work with Gigabyte's motherboards. Apparently, the only motherboards the RGB illumination is somewhat (somewhat as in apparently the Asus owners are having issues too) is Asus.

                    Do we need to initiate a class action lawsuit?

                    Please fix your memory compatibility. There is ZERO reason this should not work with Gigabyte's (and other manufacturers) motherboards OTHERWISE YOU NEED TO STATE THAT THE RGB FUNCTION IS ONLY COMPATIBLE WITH A GIVEN MANUFACTURERS MOTHERBOARD, WHICH FROM A LEGAL PERSPECTIVE, YOU'VE COMPLETELY FAILED TO DO.

                    Fix your product please.

                    First time, and possibly last time customer.

                    Relevant information:

                    Intel i7 8700k
                    Windows 10 1703 Creators Update
                    Nvidia GTX 1080 Ti
                    Gigabyte Z370 Aorus Gaming 7, BIOS F4

                    Comment


                    • For the past 2-3 weeks now I'm having issues with my 64GB (4x16) - I just cant set all Memory in Blue!? > One stick stays on rainbow effect?

                      I open software and its reading 3 out of 4 modules, so I uninstalled, reinstalled software a few times and I get this :

                      - Failed AXSP service or - No Modules found.

                      Yet, I see all modules LED on as if no issues, but again one not in color sync with the rest??
                      I turn LED switch off and that one Stick stays on rainbow effect while the other 3 are off???

                      I tried a few steps from others on forums and nothing seems to be working and I don't know what cause this to happen?

                      I'm a bit frustrated due to the fact > the money I spent on these Trident Z and I cant get them to work properly as intended...
                      Last edited by EXILE157; 07-28-2018, 06:50 AM.
                      Phanteks Evolv mATX TG (Black) *i7-6850K *Asus X99-M WS *Nzxt Kraken X62/Thermaltake Riing SP Series *G.SKILL TridentZ RGB Series 64GB (4x16GB) DDR4 *Corsair HX1200i *EVGA GeForce GTX 1080 Ti FTW3 Hybrid *Samsung 960 Evo M.2 500GB *Samsung 840 Evo Series 1TB SSD *Sharp Quattron 46' *Corsair K70 RGB *Corsair Dark Core *Corsair Gaming MM800 *Corsair ST100 *Skullcandy Crusher *Mod Mic 4

                      Comment


                      • As far as I know there is a 'RGB' signature in SPD of all G.Skill RGB-capable DRAM modules. If it is corrupted, G.Skill software can't find the modules. Start your investigations with checking SPD of all your modules.

                        Comment


                        • Here we go again!!! This software is horrible!!!...It works then it doesn't, It works then it doesn't, It works then it doesn't!!! Today is the day I have one Stick in Blue and the rest in Rainbow effect!...The custom settings doesn't last 2-3 days, it goes right back to rainbow with 1 or 2 sticks solid Blue!?

                          I've done everything within the "work around steps" suggesting what to do in this from and from other forums, but this horrible software keeps doing the same thing over and over again.

                          G.Skill are you guys listening!? Are you guys going to create a new update to this issue!? Most of us are having.....
                          Phanteks Evolv mATX TG (Black) *i7-6850K *Asus X99-M WS *Nzxt Kraken X62/Thermaltake Riing SP Series *G.SKILL TridentZ RGB Series 64GB (4x16GB) DDR4 *Corsair HX1200i *EVGA GeForce GTX 1080 Ti FTW3 Hybrid *Samsung 960 Evo M.2 500GB *Samsung 840 Evo Series 1TB SSD *Sharp Quattron 46' *Corsair K70 RGB *Corsair Dark Core *Corsair Gaming MM800 *Corsair ST100 *Skullcandy Crusher *Mod Mic 4

                          Comment


                          • First time posting here. I find it funny you guys have a specific forum post for just issues related to this horrible software! The fact you do should tell you how bad it is! I have to reinstall this application about every 3-5 days because it will just randomly stop working at all. Like today. Booted up PC, and the colors and pattern I use are not working. It's just showing default RGB colors in rotation. The app will not open either. I saw your post about what to do if this happens and I do not have a mobo that has this issue.

                            My specs: https://pcpartpicker.com/list/FJrZFt

                            So any suggestions or maybe you should just try FIXING IT on your end?

                            Comment


                            • Originally posted by Chad711 View Post
                              First time posting here. I find it funny you guys have a specific forum post for just issues related to this horrible software! The fact you do should tell you how bad it is! I have to reinstall this application about every 3-5 days because it will just randomly stop working at all. Like today. Booted up PC, and the colors and pattern I use are not working. It's just showing default RGB colors in rotation. The app will not open either. I saw your post about what to do if this happens and I do not have a mobo that has this issue.

                              My specs: https://pcpartpicker.com/list/FJrZFt

                              So any suggestions or maybe you should just try FIXING IT on your end?
                              That's why I bought non-RGB RAM. Too many problems with the software conflicting with other pieces of software. It isn't worth the hassle until G. Skill, Asus and other manufactures figure out their RGB crap.
                              Work-in-progress

                              AMD Ryzen 7 1700X
                              Arctic Cooling Freezer 360
                              Asus Crosshair VI Hero
                              32GB (4X8) F4-3600C15D-16GTZ - G.Skill took too long getting their act together with their RGB RAM!
                              2X Sapphire Nitro+ RX 580 8GB
                              Samsung EVO 960 500GB
                              3X Seagate 3TB SATA3/7,200RPM
                              LG 16X Blu-Ray/DVD Writer
                              SilverStone Strider 1200 Watt
                              Phanteks Enthoo Luxe Tempered

                              Comment


                              • It has to be the Software and GSkill knows that for a fact. What I really hate is that GSkill keep's you trying steps, steps, steps trouble shooting the issues we're all having instead of fixing the Software!

                                This is my first time since (1998) that I decided to go with GSkill and I'm very disappointed with this annoying (dual or single) module not synchronizing with others, I'm about to post my 64GB (4x16) GSkill's on OfferUp, LetGo and Ebay and go with Corsair's RGB Vengeance Pro...
                                Phanteks Evolv mATX TG (Black) *i7-6850K *Asus X99-M WS *Nzxt Kraken X62/Thermaltake Riing SP Series *G.SKILL TridentZ RGB Series 64GB (4x16GB) DDR4 *Corsair HX1200i *EVGA GeForce GTX 1080 Ti FTW3 Hybrid *Samsung 960 Evo M.2 500GB *Samsung 840 Evo Series 1TB SSD *Sharp Quattron 46' *Corsair K70 RGB *Corsair Dark Core *Corsair Gaming MM800 *Corsair ST100 *Skullcandy Crusher *Mod Mic 4

                                Comment

                                Working...
                                X