No announcement yet.

Post your issues with the Trident RGB Control software here

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hi neoilha,

    Did you have the BIOS updated?


    • #17
      yes the latest bios 1.30 - 2/20/2017


      • #18
        Originally posted by G.SKILL View Post
        Hi n2nshadow,

        Would you mind listing your motherboard model, BIOS version, memory model number, and Windows version (e.g. Windows 10 Pro 64-bit, English US) for us? We'll see if there's anything we missed that'll cause the sticks to get stuck.

        I'm using a MSI Z270 Gaming Pro Carbon

        bios is the latest 1.30

        Memory Model F4-3600C17Q, 2 in each machine.
        Even after swapping the ram to another machine it still remains lit wrong.

        I'm out of ideas, contacted Newegg for replacements. Hopefully they allow me to replace only 2 instead of all 4, so my machines can continue to run.


        • #19
          Hi n2nshadow,

          Replacing only 2 modules isn't really recommended, especially if it's a high spec memory kit, because it's very likely to run into pairing issues. Unless you plan on matching the original 2 on one system and the replaced 2 modules on another system.

          Alternatively, if you can hold until next week, we're planning to have another software version up and see if that would help resolve the issue.


          • #20
            Motherboard: Gigabyte z270x Ultra Gaming
            BIOS Version: f4
            RAM: TridentZ RGB - f4-3000C16D
            OS: Windows 10 Pro - 64GB

            I also have have a similar case to what happened with Gameface's RAM.

            After installing the software, the same thing happened to my RAM. One of the two sticks is stuck with just a pale pink light showing near the bottom part. The other stick is working fine but I can't use the software to control it since crashes on launch every time. I tried reinstalling the software but the error still occurs and I can't get past launch.

            I also tried using the sticks on the different slots but the broken one is still showing the same pale pink light at every ram slot that I tried.

            I hope this is just a software issue. For the mean time, is there any way to at least get both the RAM sticks back to its default setting? I know it's just aesthetics but the RAM sticks look hella bad on my PC.


            • #21
              Thanks for responding, seems we are all having the same problem.

              I will hold off on the rma for a bit, but I would be doing as you said. Sending the pair in my wife's PC back, putting one of mine in until the 2 are returned, so they stay paired.

              Hopefully it's a software issue, or perhaps they can give us something to clear what ever is causing the led's to be stuck.


              • #22
                How in general is managed RGB Control! MSI Mystic Light is not supported? Even in the future?
                It would be better implement management by updating/reprogramming EEPROM devices, and would not need to make compatibility with different motherboard manufacturers. would need only to update the SMBus driver. the easiest way!
                I hope in the future will be forever change the color and keep it off, then remove Trident RGB Control software.
                Last edited by jjxaker; 03-03-2017, 11:57 AM.


                • #23
                  Dark Sticks

                  all 4 sticks went dark on me... followed the suggestion on unplugging the power ... unplugged power cord, removed 24 pin and 4+4 pin connector for the mother board for good measure... allowed it to sit off for 4 hours then brought it back online... still dark...

                  good news though i fiddled and fiddled with various aspects of running the .exe under the software directory.... for the most part is crashed every time... but for some reason eventually 3 sticks light back up into the default rainbow mode... leaving 1 dark... so i repeated the steps.. seriously no rhyme or reason just uninstall , reinstall run app as admin , compatibility mode etc.. basicly anything i could think of.... and sure enough eventually the last stick came to life again... default rainbow mode... at this point i have removed all the g-skill software.... and i have 4 sticks running in rainbow mode

                  Gigabyte GA-Z270X-Gaming 9 (rev. 1.0) Bios f3 2017/02/20
                  (all apps/utils/drivers for M/B have been update from the manufacture web site)

                  intel 7700 k

                  Gigabyte G1 1080 gtx

                  G.SKILL TridentZ RGB Series 32GB (4 x 8GB) 288-Pin DDR4 SDRAM DDR4 3866 (PC4 30900) Desktop Memory Model F4-3866C18Q-32GTZR


                  • #24
                    the app wont open for me, i get an error that no tridentz rgb modules are on my system and the app auto closes.

                    motherboard: msi z170a gaming m5 with latest 1.D bios. two tridentz rgb modules on primary ram ports.


                    • #25
                      Just as a general question to see if it's a possible cause. For those of you who are having issues with the module lighting stuck in off when the Trident Z RGB software is installed, are you also using the motherboard lighting control software at the same time?


                      • #26
                        The software works fine here. The only problem is that when installing Trident Z RGB Control, Asus Aura stops working and its not possible to change the colors on the rest of the motherboard, everything else goes black. So after installing Trident Z RGB Control, Asus Aura fails to work. I was hoping and hope that the Software for Trident Z RGB will work separate from Asus Aura.

                        Is this software made together with Asus, it looks very much as Asus Aura

                        MAXIMUS IX HERO BIOS 0801
                        Last edited by OleMorten; 03-04-2017, 11:51 AM.


                        • #27
                          Originally posted by G.SKILL View Post
                          Just as a general question to see if it's a possible cause. For those of you who are having issues with the module lighting stuck in off when the Trident Z RGB software is installed, are you also using the motherboard lighting control software at the same time?
                          Yes, I am also using RGB fusion on my Gigabyte motherboard (GA-Z270X Gaiming 7)

                          I will follow your instructions to the letter and see what happens. I will try to find out how to disable the RGB fusion software, but that will likely disable all my motherboard RGB which is kind of part of the whole RGB effect that these Trident Z RGB sticks are part of.

                          I'm happy for the responses. I have to say I'm bummed but I hope I'm not coming off as being too negative. This RAM looks fantastic when working. It is absolutely the centerpiece of my new build, looks-wise, anyway.

                          Here's a pic of my build, it is in the ThermalTake Tower 900 "Showcase"

                          Gigabyte Z270 Gaiming 7 (GA-Z270X Gaiming 7) BIOS F4
                          Intel i5 7600k
                          Gigabyte GeForce GTX 1070 G1 (GV-N1070G1 GAIMING-8GD)
                          4x G.Skill Trident Z RGB (DDR4 2400 - PC4 19200)
                          1TB Samsung 960 EVO
                          Win10 Home 64bit


                          • #28
                            I am running the Asus ROG MAXIMUS VIII HERO ALPHA Motherboard. The only two options that "semi" work are the the Rainbow or Color Cycle. When I try any other setting slot #3 doesn't change and gets stuck on the previous setting. I have swapped out the memory in slot 3 with another module and it still has the same issue.


                            • #29
                              To the G.SKILL admin: Will there be some sort of changelog documented somewhere to see what changes have been made in new revisions of the software?


                              • #30
                                yes changelog and compatibility list would be useful. does the motherboard need to have aura?