No announcement yet.

Trident Z: 2 of 4 sticks not recognized by BIOS & OS, visible from CPU-Z

  • Filter
  • Time
  • Show
Clear All
new posts

    They should all work the same. Send them in for RMA and a new kit should work better.

    What date did you purchase the memory kit? Within 30 days of purchase the vendor should be able to replace it right away.

    Leave a comment:

  • Trident Z: 2 of 4 sticks not recognized by BIOS & OS, visible from CPU-Z

    So I've recently bought 4x8GB pack of Trident Z (F4-3200C16Q-32GTZKW).
    MB: AsRock X299 Taichi XE
    CPU: Intel Core i7 7820X
    Unfortunately 2 out of 4 sticks seem to be faulty - they aren't recognized by BIOS and OS, so I only got 16 GB in dual-channel mode. I've tried reseating them into other slots and it seems that the problem is with the sticks since mobo always reports the slots occupied by them as "empty".
    Also trying to run the system only with these 2 sticks results in a POST failure ("Error 0x55 - No usable memory").
    However CPU-Z does report the full 32 GB and it shows the 4 slots as populated, correctly recognizing RAM model & specs. The same goes for "DRAM Tweaker" utility from the BIOS - it shows all 4 sticks.
    Apart from reseating the sticks, I've tried different JEDEC profiles as well as the XMP profile that has been running by default, all to no avail. I did not raise any voltage params higher than they are in XMP though yet as I'm not really an expert.
    Is there anything I can do before RMAing my memory? The other 2 sticks seem to work perfectly fine, would be great if there is a way to fix it.

    Thank you!