No announcement yet.

F3-10666CL9D-8GBRL + Intel DH55HC + i3 550 @ 3.20GHz

  • Filter
  • Time
  • Show
Clear All
new posts

  • F3-10666CL9D-8GBRL + Intel DH55HC + i3 550 @ 3.20GHz

    I am attempting to install 2 additional 4BG modules of F3-10666CL9D-8GBRL. Original RAM is same model, but manufacture date Dec 2010.

    With all 4 modules installed, I'm getting a hard (like power supply failure) reboot loop when starting Windows. After removing original modules and trying new modules (tried both together and 1 at a time), I'm getting a quick (no power blip) reboot loop when starting Windows.

    So far, I have reset CMOS and updated BIOS to lastest version.

    After reading this thread regarding double-sided vs single-sided modules, I believe I need to exchange for this:


    At this point, I would like to confirm that I should exchange the modules for the NT version, or is there some BIOS configuring I can look into?

    Additionally, does the hard reboot loop w/the full 16GB mean I have a power supply issue as well?

    Disclosure: I'm extremely limited in hardware knowledge, and even less so in BIOS.

    Thanks in advance for any help you can provide.
    Last edited by iahawk; 04-11-2017, 12:14 PM.

  • #2
    Yes, the NT model should work much better. The kit should be plug and play. Make sure you have the latest BIOS.
    Are you an overclocker? Have screen shots of your OC results? Please post and share your OC experience!

    The new G.Skill Overclocking Section!


    • #3
      Thank you!