Announcement

Collapse
No announcement yet.

Need Help with G.Skill TridentX PC3-19200 32GB (F3-2400C10Q-32GTX)!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need Help with G.Skill TridentX PC3-19200 32GB (F3-2400C10Q-32GTX)!

    Hello!

    I have an Asus Gryphon Z87 motherboard that is supposed to be able to take up to 32GB of memory. I got this particular memory kit, but unfortunately, it doesn't post if I use all 4. I am currently using two of the four at 2400Mhz (XMP Profile 1), and I could use some advice on how to make all four work on my motherboard. I've tried lowering the speeds all the way down to 1600, but it still won't post. Yes, I've tried the memOK button on the board.

    I'd appreciate any help you can give me. Thanks in advance!

  • #2
    Any two modules can run fine at 2400? With 4 modules installed, the system should at last be able to boot. Do you have the latest BIOS?

    Which slots do you have the RAM installed in?

    Comment


    • #3
      Aye, any 2 of them work with each other, but only 2. I am using the first and third (counting from nearest the CPU) slot. Given that this is a dated motherboard, I do appear to have the latest bios from Asus (flashed it like nearly 4 years ago).

      Comment


      • #4
        Do you know the history of the motherboard? Has it worked fine previously?

        Initial slots for the motherboard should be A2 B2, second and fourth slots away from the CPU.

        Comment


        • #5
          I am the first owner of this motherboard, it hasn't had any issues with memory in the past. This is the first time I am attempting to use a 4-piece memory kit, though.

          Comment


          • #6
            May be an issue with the motherboard or CPU. I suggest checking the CPU socket pins to make sure they are perfect. Most likely it will be necessary to try other hardware to troubleshoot the issue.

            Comment


            • #7
              Alright, thanks.

              Comment

              Working...
              X