No announcement yet.

8GB DDR2 667 on Latitude E6400

  • Filter
  • Time
  • Show
Clear All
new posts

  • 8GB DDR2 667 on Latitude E6400

    Hi folks,

    Working on a Latitude E6400.
    Model of the motherboard: Dell 0U695R
    Model of the memory: F2-5300CL5D-8GBSQ
    Model of the CPU: Intel Mobile Core 2 Duo P9700

    This laptop always had 2x2GB memory, and I decided to upgrade to 8GB in February of this year to prepare for a conference in April. I purchased G.SKILL's F2-5300CL5D-8GBSQ for this. I installed the memory, and was promptly greeted by the following message on boot:

    Memory read/write failure at D69EDEF0, read 9E319E71 expecting 9E719E71
    To resolve this issue, try to reseat the memory
    Decreasing available memory
    I tried reseating, no change (except the address/values). Tried using each stick in DIMM A, no problems. Tried my old RAM, no problems. Tried swapping which new stick I used in which DIMM, got the original error again. Then, suddenly, on a try where I did nothing new, voila, it booted up.

    While I was uncomfortable with this and expecting the system to crash at any moment, I screwed my back panel back on and left it alone. I was able to use the laptop at the conference in April for a full week with not a single issue. I don't use the laptop frequently, but pulled it out again today to use, and had an unrelated problem for which I tried to open the boot menu.

    Boom. Original error is back.

    It's possible I could keep trying to boot this thing and eventually it would work, but I'd like some answers. My only theories have been 1) the MOBO isn't providing enough voltage to the memory, or 2) that I have a bad stick of memory. I'm not happy with either of those theories though because 1) CPU-Z says it's giving my old memory 1.8V right now which should be plenty (if I'm reading this right - 1.8V seems high to me), and 2) while the memory was working for the past few months, I had not a single issue with it, which seems unlikely if one of the sticks was faulty.

    It seems like the BIOS is testing the memory under certain conditions, and while this memory rarely passes the test for some reason, it passed once, and since I never opened the boot menu again, it wasn't tested again. Now, when I reopened the BIOS, it tried the test again, and of course failed again. What I'm not sure of is why the memory seems to be fine but doesn't pass the BIOS's test. The BIOS is at version A34, by the way, which is the last release for the Latitude E6400.

    Let me know if any additional information is needed. Would really like to get this working.

  • #2
    So problems only occur when you have two modules of the newer RAM installed?

    Have you tried a memory test to see if any errors are detected?

    If problem persists, you are more than welcome to send them in for RMA exchange to see if a replacement works better.


    • #3
      I believe I've seen it fail the same way with one module installed, but it almost always seems to work when only one module is installed.

      I ran Memtest86 on one of the modules today by itself and it didn't find any errors. Will run against the other module tomorrow.

      Regardless, if you think an RMA for replacement is worth trying, I might. I'm not convinced there's a problem with the modules but I don't personally have any other ideas.


      • #4
        I ran Memtest86 on the other module, and it passed.
        I also ran Dell's diagnostics against one stick in DIMM A, it passed, then ran it against the other stick in DIMM B, it passed. Trying to see if there's an issue with either one stick or one DIMM.
        I guess I'll RMA, because I don't really know that there's any other potential solution. My BIOS doesn't give me any options to tweak, so I'm kind of stuck there. Unfortunately I can't even test when both sticks are installed, because my BIOS doesn't even let me get to the boot options, it stops at the memory error before it can get there.


        • #5
          FYI: Returned the sticks for RMA. Just installed the RMA replacement, laptop booted up with no issues. Looks like there must have been an issue with the old sticks.


          • #6
            Great to hear you got that sorted out! Enjoy!