Announcement

Collapse

UNDER CONSTRUCTION: G.Skill Forum

Hello Everyone

The G.Skill Technical forum will be under construction during the month of February. There may be random down time, so we sincerely appreciate your patience and cooperation during this time. We are excited to bring you a more interactive forum to share information. For any technical assistance or issue that may require more attention, please contact us directly via other methods such as email, telephone, social media, NewEgg Chat, and more. Support is available through any avenue you can reach us.

ustech@gskillusa.com
techsupport@gskill.com


We hope for a quick and smooth transition

Thank you for your understanding

GSKILL SUPPORT
See more
See less

NEW G.SKILL website!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Oh I agree, have seen some that look really good on paper, but haven't had one in my hands in a long time that I was happy with


    Pls offer comments on support I provide, HERE, in order to help me do a better job here:

    Tman

    Comment


    • #17
      Seems on the face of it, there is a hassle getting into the new G.Skill Site Forums. I have had an account there for ages, but after the new site went in, all I get when trying to enter the Forums is:

      ================
      Hello, seems like you have already registered with ASUS before, using:
      XXXXXXXXXXXXXXXXX (sic: my X's ..... its my full email address in reality)

      In order to grant you access to the new ROG Forum, we need to optimise your ASUS account for the ROG Forum.
      All you need to do is setup an User Name, so your ROG buddies know how to call you.
      This process will only need to be done once.
      ==============

      "......... only need to be done once " - add a zero rofl

      I've stopped trying to access the forums for now, just to let the new site settle, but its frustrating not being able to get in, even more not being able to say I cant get in, as I need to be on the Forum to do that rofl

      Anyone else had the hassle? If not, I'll scratch me head and try to figure out why the damn thing keeps yelling at me to enter details that ".... only need to be done once".

      Each time I enter them all I get is spinning circular arrows, and a wait sign - one time I let it run for an hour in a separate window, still wouldn't play, was stuck in the "spinning" mode.

      Likely its settling in troubles on the new site, but frustrating nonetheless

      Comment


      • #18
        Interesting, didn't even know Asus had a area dedicated to GSkill, will have to check it out (I basically never go to their forums)


        Pls offer comments on support I provide, HERE, in order to help me do a better job here:

        Tman

        Comment


        • #19
          This is the ASUS ROG Guide for my ROG 3960x motherboard

          http://rog.asus.com/46212011/rampage...verclocking-2/

          Comment

          Working...
          X